XenApp 5 Windows Server 2008 Hot Fix Rollup fails to install

XenApp 5 on Windows Server 2008 SP2 (VM in Xenserver) Hot Fix Rollup R01 fails to install with following error.

Installation ended prematurely, because of an error.

Install fails with same error either installing thru GUI or command line. Anyone run into this problem?

Ideas are appreciated.
Thanks!
LVL 1
rojiruAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

barrykflCommented:
could u try use add/remove feature in termianl service ? ...

http://technet.microsoft.com/en-us/library/cc742815.aspx
0
rojiruAuthor Commented:
Not sure about the add/remove feature, but placing server in /install mode receive same error.

I may just have to break down and upgrade XenApp.

Thanks!
0
barrykflCommented:
SEEM someoen expereience your status before:

have a look:

http://davestechnology.blogspot.hk/2012/11/installation-ended-prematurely-because.html
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

rojiruAuthor Commented:
Thanks, but registry setting already set to 0. Below is tailing of the log of the install via command line msiexec. Maybe this will help for anyone that is more knowledgeable in msiexec operation. Installing via command line or GUI results in same error.

Action ended 20:57:40: CTX_CDF_MM_StartLogSession.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4. Return value 1.
Action start 20:57:40: CTX_CDF_MM_InsertStopSessionCAs.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4.
CTX_CDF_MM_InsertStopSessionCAs: Entering ...

CTX_CDF_MM_InsertStopSessionCAs: Existing Record Cancel,Yes,EndDialog,Exit,1,

CTX_CDF_MM_InsertStopSessionCAs: New Record Cancel,Yes,DoAction,CTX_CDF_MM_StopLogSession.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4,1,1

CTX_CDF_MM_InsertStopSessionCAs: Existing Record Fatal_Error,OK,EndDialog,Exit,1,522

CTX_CDF_MM_InsertStopSessionCAs: New Record Fatal_Error,OK,DoAction,CTX_CDF_MM_StopLogSession.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4,1,523

CTX_CDF_MM_InsertStopSessionCAs: Failed to insert the record 1627

CTX_CDF_MM_InsertStopSessionCAs: Leaving ...

Action ended 20:57:40: CTX_CDF_MM_InsertStopSessionCAs.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4. Return value 1.
Action start 20:57:40: CtxProcessCtxRequiredInstallDlls.2FC063C6_B4B7_4E0E_B5A1_DD207D00E9C7.
CtxProcessCtxRequiredInstallDlls failed with error code 3
Action ended 20:57:40: CtxProcessCtxRequiredInstallDlls.2FC063C6_B4B7_4E0E_B5A1_DD207D00E9C7. Return value 3.
Action start 20:57:40: Fatal_Error.
Info 2898. For MSSansSerif8 textstyle, the system created a 'MS Sans Serif' font, in 0 character set, of 13 pixels height.
Action start 20:58:12: CtxCleanupCtxRequiredInstallDlls.2FC063C6_B4B7_4E0E_B5A1_DD207D00E9C7.
Action ended 20:58:12: CtxCleanupCtxRequiredInstallDlls.2FC063C6_B4B7_4E0E_B5A1_DD207D00E9C7. Return value 1.
Action start 20:58:12: CTX_CDF_MM_StopLogSession.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4.
Action ended 20:58:12: CTX_CDF_MM_StopLogSession.D4E6CDE7_FAC1_458B_8935_048A9A1DB4A4. Return value 1.
Action ended 20:58:12: Fatal_Error. Return value 2.
Action ended 20:58:12: INSTALL. Return value 3.
=== Logging stopped: 8/28/2013  20:58:12 ===
MSI (c) (C0:10) [20:58:12:594]: Product: Citrix XenApp 5.0 - Update 'XAE500W2K8R01' could not be installed. Error code 1603. Additional information is available in the log file C:\Tools\xa3.log.

MSI (c) (C0:10) [20:58:12:595]: Windows Installer installed an update. Product Name: Citrix XenApp 5.0. Product Version: 5.0.2. Product Language: 1033. Update Name: XAE500W2K8R01. Installation success or error status: 1603.

MSI (c) (C0:10) [20:58:12:599]: Product: Citrix XenApp 5.0 -- Configuration failed.

MSI (c) (C0:10) [20:58:12:600]: Windows Installer reconfigured the product. Product Name: Citrix XenApp 5.0. Product Version: 5.0.2. Product Language: 1033. Reconfiguration success or error status: 1603.
0
basrajCommented:
Check the log files (c:\tools\xa3.log) as well as event viewer to see if you find any clues. Re-download the hotfix and try again (to make sure downloaded file isn't corrupt)
0
barrykflCommented:
try basraj suggestion c:\tools\xa3.log ....mostly u download wrong package

can u try msiexec /fa  force reinstall the package by command ?
0
rojiruAuthor Commented:
Funny thing that the log file refers to itself. This is the tail of xa3.log. I've downloaded the file 3 times to 3 different locations, and get the same result. I have a case open with Citrix, and have received some recommendations. I've followed the recommendations, except migrating to MSSQL server. The data store is running on MSDE. I've checked the requirements, and the installed XenApp 5 meets the requirements for the Hot Fix Rollup 1. No solution yet. I have another Xenserver that I will copy the VM over to conduct testing. Just thought I'd check here for any possible solutions.

Thanks!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rojiruAuthor Commented:
Citrix engineers recommend uninstalling hotfixes already applied, then try installing Rollup pack 1. We shall see how this works out.

Thanks for everyone's input!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.