transferring data from old XP hdd to new Win 7 - Getting lock symbol on files - how to remove

Error on open files - you dont have perm
"you dont have the correct perms to access the file location"

Ive transferred most data over.
Lock symbol appearing

Ive heard Total Commander will undo file perms in one click?

Is that true ?
Where to get a good copy of it?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

You could also try changing the owner under the folder/files security tab. When you change the owner, tick the box that says "Replace owner on subcontainers and objects", apply it and close the folder's properties box.

Then bring up the properties box again, and change the permissions to whatever you need them to be (tick the box that says "Replace all child object permissions with inheritable permissions from this object" to save time).
Joe Winograd, Fellow&MVEDeveloperCommented:
I've been using Total Commander for decades, but never to undo file permissions. There are many commands that it can perform on multiple files in a single click, so perhaps it can do it, but I don't know.

It is a shareware product and you may try it for free to see if it can do what you want. Download is here:

If you need help figuring out how to do it (or even if it can do it), the program's author, Christian Ghisler, responds promptly to email support requests at:

It is a phenomenal file manager. I wouldn't be without it. Regards, Joe
☠ MASQ ☠Commented:
Total Commander download links are on the author's site here:

But it just does what adriaanvw describes above.
SandeepSr System AdministratorCommented:
Refer to below Microsoft link which will guide you how to take ownership of the folders.

As you have connected your old HDD to new Windows 7, I would suggest right click on the Drives one by one from that old HDD. Go to Security tab, and take ownership for Administrators Group or Administrator User ID or your Administrator account. Make all access as Full and also make sure the replace child objects option is also checked. This will enable all the child objects to have new permissions and you will not see the Lock again for your files.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.