having trouble setting up local domain

I have a public domain: xyz.org. Behind my firewall I have a SBS 2008 server, server 2008 database server, linux webserver and linux file server. There are an additional 10 domain connected Windows workstations.

The SBS 2008 machine is the main DNS server and the DHCP server. The office has basically 2 domains: the local windows domain xyz.local, and the publicly visible domain xyz.org.

The linux web server has a static IP and it's dnsdomain is xyz.org. There are no issues with this computer.

My problem is with the linux file server. I have several problems, in fact, but one at a time. This host is supposed to be a local host only - not visible to the Internet. I've configured it to get a dynamic IP address from the SBS server and I've set it's dnsdomain to xyz.local.

Problem 1: from this file server I can connect to the webserver via e.g. ssh@webserver.xyz.local, telnet webserver.xyz.local, etc, but I cannot see the public domain xyz.org:

$ ping webserver.xyz.org
ping: unknown host webserver.xyz.org

yet I can see other public domains, e.g. yahoo.com:

$ ping yahoo.com
PING yahoo.com (98.138.253.109) 56(84) bytes of data.
64 bytes from ir1.fp.vip.ne1.yahoo.com (98.138.253.109): icmp_req=1 ttl=53 time=32.5 ms

What is my problem? It seems like my SBS 2008 DNS server is resolving external public domains, but isn't resolving the public domain it is hosting.
LVL 1
MarkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

clement_nussCommented:
It looks like a DNS issue, clearly !

On your Windows DNS server, which DNS servers are set ? If you've set an other DNS (in the network card configuration page), it needs to be in second position.

You can too try on a windows computer to lookup DNS records on Windows server using the command : nslookup - "your dns server ip"
e.g. nslookup - 10.1.2.3

Then type xyz.org and check the output. Maybe the problem isn't on the linux server side, but on the Windows server.
0
MarkAuthor Commented:
clement_nuss: > On your Windows DNS server, which DNS servers are set ?

Here is the image of the network card setup on the Windows DNS server:
DNS Server network propertiesAs you can see, it has itself as the only DNS. That's a bit odd since what does it use for up-stream DNS? The gateway, 192.168.0.1 is the firewall/router, and it does have ISP DNS IPs specified. Does it go to the gateway for DNS resolution?

I put 192.168.0.1 in as the 2nd (Alternate) DNS server, but no improvement.

> You can too try on a windows computer to lookup DNS records on Windows server using the command : nslookup - "your dns server ip"

Here are my results from that:
C:\Users\mark>nslookup 192.160.0.2
Server:  mail.hprs.local
Address:  192.168.0.2

*** mail.hprs.local can't find 192.160.0.2: Non-existent domain

Open in new window

If I try looking up using the public domain name I get:
C:\Users\mark>nslookup ohprs.org
Server:  mail.hprs.local
Address:  192.168.0.2

Name:    ohprs.org

Open in new window

That seemed to work. If I try the IP using the gatway as the name server it doesn't work:
C:\Users\mark>nslookup 192.160.0.2 192.168.0.1
Server:  UnKnown
Address:  192.168.0.1

*** UnKnown can't find 192.160.0.2: Non-existent domain

Open in new window

Does this all tell you anything?
0
MarkAuthor Commented:
more info:

If I send an email from the linux file server to a user on the linux webserver, it gives the following error on the webserver:

# (on file server)
$ mail -r dumper@webserver.ohprs.org sysadmin@webserver.hprs.local

# (on webserver)
   ----- The following addresses had permanent fatal errors -----
sysadmin@webserver.hprs.local
    (reason: 553 5.1.8 <dumper@webserver.ohprs.org>... Domain of sender address dumper@webserver.ohprs.org does not exist)
    (expanded from: sysadmin@webserver.hprs.local)

If I ping webserver.ohprs.org FROM webserver.ohprs.org, it works! But if I do nslookup from webserver I get:

$ nslookup webserver.ohprs.org
Server:         192.168.0.2
Address:        192.168.0.2#53

** server can't find webserver.ohprs.org: NXDOMAIN

Clearly, something is messed up! The webserver has the following in the /etc/resolv.conf file:

domain hprs.local
nameserver 192.168.0.2
nameserver 66.193.88.2
nameserver 8.8.8.8
# nameserver 66.193.88.3

If I specify one of the other name servers, it find it:

$ nslookup webserver.ohprs.org 8.8.8.8
Server:         8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
Name:   webserver.ohprs.org
Address: 64.129.23.95

I am sooooo confused! Clearly, as clement_nuss suggested, there must be something wrong with the Windows DNS server (since it cannot locate the hprs.org domain, but 8.8.8.8 can). But what is wrong and how do I fix it?
0
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

MarkAuthor Commented:
more info:

OK, the ping webserver.ohprs.org worked because that FQDN was in the /etc/hosts file. When I remove it from the /etc/hosts file, pinging doesn't work either. Which is more consistent.
0
clement_nussCommented:
well , with the nskookup command you need to use a - ( score) when you want to specify which server you're using : nskookup - 192.168.0.2.       and then enter the domain you're looking for.

But apparently the windows server isn't giving the right addresses to your local network. try looking up the properties of your ohprs.org zone, and look if it has some rules to only serve some ips. it may too be a spelling error, because the DNS servers don't look to be your local 192.168.0.2 - mail.hprs.local. then there may be a mistake in this server, you talked somewhere of a hprs.org and too of ohprs.org, which exists on the net.

try then first : nskookup - 192.168.0.2.    and ask the DNS server about ohprs.org and about hprs.org, and see if everything is ok. the linux server probably hasn't any got any DNS problem , the resolv.conf is looking to be all right.

hope this will help !
0
MarkAuthor Commented:
> you talked somewhere of a hprs.org

That was at the end of my post 39451280 and was a typeo. There is only one public domain: ohprs.org.

> with the nskookup command you need to use a - ( score) when you want to specify which server you're using

Well, the score/dash just enters interactive mode. It works without, and you'll notice that my examples show it working with a different DNS server.

I can now do the nslookup from a Windows workstation:
C:\Users\mark>nslookup 192.168.0.2
Server:  mail.hprs.local
Address:  192.168.0.2

Name:    mail.hprs.local
Address:  192.168.0.2


C:\Users\mark>nslookup ohprs.org
Server:  mail.hprs.local
Address:  192.168.0.2

Name:    ohprs.org


C:\Users\mark>nslookup ohprs.org 192.168.0.2
Server:  mail.hprs.local
Address:  192.168.0.2

Name:    ohprs.org

C:\Users\mark>nslookup ohprs.org 8.8.8.8
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    ohprs.org
Address:  64.129.23.80

Open in new window

Notice in the above that I can lookup the DNS server IP (example 1) and it returns the IP and local FDQN of that machine: mail.ohprs.org. In example 2 I lookup the ohprs.org domain and it comes back with the LAN IP of the domain/DNS server and its local FQDN. Example 3 does the same, but I specify the IP of the domain/DNS server to use as the look-up server. It also returns the local FQDN. I'm not sure this is what I want. If I specify the public domain name why does it not return the public IP?

The last example show a lookup of the domain name, but I specifiy a nameserver provided by the ISP. This does, in fact, return the public domain name and public IP.

I'm not sure what I did to get this far. What I did was remove the self-reference of the DNS server in the NIC config and add the gateway and one of the IPS's DNSes (see attached image and compare with image above).

Note that with this setup I still cannot find the ohprs.org domain from the linux web server unless it is explicitly entered in /etc/hosts:

$ ping webserver.ohprs.org
ping: unknown host webserver.ohprs.org

I need to step back and get some explicit setup help:

1.  My NIC card setup screen-shot in posting ID: 39451246 shows the DNS address the same as the DNS server for the DNS server itself. Is this correct or should it point somewhere other than itself (is my new setting show in the current image correct)?

2. What specific configuration steps should I take either on the DNS server or on the linux host to get the linux host to be able to resolve the ohprs.org domain? I think I need this to happen before I can successfully get rid of the email error message.
newNIC-DNS.jpg
0
MarkAuthor Commented:
clement_nuss, I'm going to also post this last bit as a separate question, devoid of all the clutter ...
0
clement_nussCommented:
Well, examples 2 and 3 are the same in fact, the default DNS server on the windows computer is 192.168.0.2. But anyway, your 192.168.0.2 DNS server doesn't return any address for the ohprs.org domain. Did you run these commands on the windows server ?

To be clear : the output of a nslookup is made of two part : one who speaks about the dns server you're querying IP addresses, and a second part in which the infos you're asking should appear. Then if you ask the 192.168.0.2 dns server or the mail.hprs.local it is the same.

The best config is normally to set the dns server (Windows here) itself as the first dns server in the NIC configuration, but if you only put e.g. 8.8.8.8 dns server, you should be able to resolve ohprs.org. There are too some settings in the DNS server itself about the DNS resolver. Right-click the DNS server in the management console and see what resolver it uses.

Think too to use the ipconfig /flushdns command, which flushes the DNS cache, and may solve some problem ! And could you too tell me if you're able on the Windows server to do : nslookup ohprs.org 127.0.0.1

Good luck !
0
MarkAuthor Commented:
The current DNS usage settings on the SBS/DNS server are shown in the image: 192.168.0.1, 8.8.8.8. So, you are saying that I *should* have 192.168.0.2 (the SBS host itself) as the 1st DNS server and, if I want, the 8.8.8.8 as alternate, right?

nslookup ohprs.org 127.0.0.1 gives me:

Server:  localhost
Address:  127.0.0.1

Name:    ohprs.org
0
clement_nussCommented:
Theorically you should, but there is an other problem, even higher !

The output of this command means that the server doesn't server the "A" record of ohprs.org. Then all other hosts on the network don't get the ip address for ohprs.org.

Check if your DNS zone is a direct search zone, and if there is an "A" record named ohprs.org and pointing to ohprs.org internet IP.

The problem comes from the SBS DNS configuration... you need to try some setting such as disable recursive research oin the advanced Tab, and try as well to create a test zone like test.local (not really original !), then you'll be sure that there won't be any doubts for this zone.)

Good luck, and don't hesitate to post nslookup outputs, it always helps!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MarkAuthor Commented:
OK, I got this one solved by creating an A record on the SBS server for webserver.ohprs.org. I'll now continue exploring the email issues and see it that helps resolve the problem and, if not, I'll be back with another post.

THX
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.