All Users Desktop

We run 2 terminal servers (Windows Server 2008 R2 Enterprise) and have several desktop icons for all users.  I have one icon that is a .url shortcut that when I try to update the url with https://  in the Properties It tells me  "Cannot make changes to this Internet Shortcut"    So I tried to ADD a new one and I get they same type of error.

What am I doing wrong?????
bankwestCTO/CashierAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jaroslav LatalMSPCommented:
try to run explorer as admin.

Jarda
0
bankwestCTO/CashierAuthor Commented:
I am an admin user
0
Jaroslav LatalMSPCommented:
I mean rightclick and "run as admin"..
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

piattndCommented:
Go to the folder of that item, right click on it, go to properties.  Make sure the file is not marked as "read only".  If it is, uncheck this, make your change, and check the box again (applying after every change you make of course).
0
bankwestCTO/CashierAuthor Commented:
The read only box is NOT checked.

JardaCZ:   Right Click on what and run as admin?   I dont have that option on the folder or the shortcut
0
piattndCommented:
The following link explains exactly what JardaCZ was saying:

http://social.technet.microsoft.com/Forums/windows/en-US/51792e52-5484-45d6-af0b-cfe7c819d9fe/hard-to-create-shortcuts-in-userspublicdesktop

You need to run Windows Explorer with elevated rights.  One way to do this is to click start > run > enter "C:\users\public\desktop" and click OK.  Notice how the run box says that these functions will be run with administrative privileges.

Now try to modify the files.
0
bankwestCTO/CashierAuthor Commented:
Ok....Playing around with this, I found a workaround.

Created the shortcut on the desktop then copied it back to the C://Documents and Settings/All Users/Desktops.

May not be the correct way but it did let me add it that way.
0
piattndCommented:
That is a workaround.  If you don't want to have to do this, you can use the method posted above.
0
bankwestCTO/CashierAuthor Commented:
C:\users\public\desktop apparently is not the path.   I am on Windows Server 2008 and it is C:\Documents and Settings\All Users\Desktop.   So did the click start > run > enter "C:\Documents and Settings\All Users\Desktop" and click OK.      Nope....Still the same error and I do not see anything on the box that says I am running elevated privileges.
0
Jaroslav LatalMSPCommented:
OK, do exatly this steps:
1, click start and type "Windows Explorer"
2, right click on it and select "run as administrator"
3, paste "C:\Users\Public\Desktop" to the address bar
4, edit shortcut

Jarda
0
piattndCommented:
C:\Users\Public\Desktop

That is the path.  I just confirmed it on my 2008 server.  To get the folder to show in windows explorer, you have to go to tools > folder options > view > uncheck the boxes to hide hidden folders and system protected folders.
0
bankwestCTO/CashierAuthor Commented:
Ok.  I did Exactly as you said.     And the path to the folder as you said.  C:\Users\Public\Desktop


I still get "Cannot apply changes to this Internet Shortcut.
0
Jaroslav LatalMSPCommented:
OK go to properties, security, take ownership and set correct permissions..

Jarda
0
piattndCommented:
This isn't a permissions issue, as you can manually copy the folder into that location.

Try this:

start > run > type "\\127.0.0.1\c$"

Open Users.  Open Public.  Open Desktop.  Try the changes.
0
bankwestCTO/CashierAuthor Commented:
Nope.    I get the same error message.
0
Jaroslav LatalMSPCommented:
It is the permission problem!
Just add the correct permission as I mentioned abowe.

Jarda
0
bankwestCTO/CashierAuthor Commented:
I did that as well.   Still not working.
0
piattndCommented:
Right click on the shortcut, click properties.  Click the security tab.  Click the advanced button.  Click the Effective Permissions tab.  Press Select and enter the name of the account you're logged on with.

What do the permissions show at the bottom of this window?  Do you have user account control turned on?
0
bankwestCTO/CashierAuthor Commented:
In effective permissions, selecting the name I am logged in as.......   All the boxes are checked.    However......I dont see a choice for user account control????   Or anything like that on the bottom of the window.   Happy to provide a screenshot if needed.
0
piattndCommented:
User account control will be under control panel > user accounts.  You should see a "change user account control settings" option.

Set this to the lowest possible setting if it is not already there.  You may need to perform a reboot for all changes to take.
0
bankwestCTO/CashierAuthor Commented:
Ok, I will try that.   I will need to wait to do a restart until afterhours so If I still have an issue, I will post again in the morning.

Thanks
0
Jaroslav LatalMSPCommented:
bankwest, i think you do not need to turn off UAC. Just the permissions..

Jarda
0
bankwestCTO/CashierAuthor Commented:
Permissions:   I have full control, being the Administrator for our domain.    And I took ownership of the file/Folder

But I still get the error
0
Jaroslav LatalMSPCommented:
Do not use group permissions (for example administrators), but add your exact login (for example CONTOSO\bankwest). Set to that user full control permission.

Jarda
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
piattndCommented:
That is not necessary.  There's no issue with group based membership.  I'm almost 100% certain this is not an NTFS permissions issue.  It's more of an internal windows security issue (like UAC or protected folder settings).
0
bankwestCTO/CashierAuthor Commented:
Jarda:    THANK YOU, THANK YOU, THANK YOU.

Once I added my exact login and gave full control (instead of the group), then it allowed me to make the change.

WHEW!!!!     Not sure why?????     But it worked.    

I am in the Group for domain admins, so I would have thought that was enough.

So again,  THANK YOU
0
bankwestCTO/CashierAuthor Commented:
Thank you so much for walking me thru this.
0
piattndCommented:
That's really odd, glad it worked for you though.  Good call Jarda, I'd still be spinning my wheels on this one as I'd never in a million years consider specific user permissions to fix it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.