Context menu gets stuck on my screen

Don't know why, not sure how, but random context menus get stuck on my screen. They are persistent on the desktop, over applications, and the only way to get rid of it is logout or reboot.

Anyone know how to fix this without a logout / reboot?
8-29-2013-10-23-14-PM.png
LVL 32
DrDamnitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sanjayrajtCommented:
hi,
Go to this video link http://www.youtube.com/watch?v=sIvpiq9Ba0I
Fix the problem.
0
Joe RudSystems AdministratorCommented:
Check for update to your video driver.
0
jcimarronCommented:
DrDamnit --
It happens from time to time for me, too.  I just open a new window of something/anything.  When I close that new window the context menu is usually gone.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

BillDLCommented:
If you are prepared to go off to YouTube and view somebody else's video that was linked to by Sanjay earlier, then feel free to try what it mentions and adapt to some erroneous instructions therein, but it would have been preferable to just post the simple instructions here instead of listening to somebody enjoying the sound of his own voice for 3 minutes.

Sanjay, the problem with just posting a link to a YouTube video is that if the user removes it, your "suggestion" will be useless to others reading this question at a later date.

Right-Click My Computer > Properties > Advanced System Settings > Performance Options.
Visual Effects tab > Settings.
OR
Control Panel > type Performance Information and Tools in the search box > select Performance Information and Tools > click Adjust Visual Effects link on the left side of the window.

Untick all the useless resource hogging "fade" and "animate" effects and click "Apply".

The video author claims ownership of "a fix", when in fact on most occasions screen artefacts like this are just caused by all the fancy GUI eye candy that is enabled by default in Windows and which uninformed users seem to love so much.  The first thing I do on any system of my own, or on other peoples' when they have complained about slow performance, is to disable all fancy effects in Windows and applications and set the whole thing to "classic" appearance.

On odd occasions where this still happens to me I just kill off Windows Explorer and restart it again using Task Manager.

Ctrl+Alt+Del (or Ctrl+Shift+Esc) > In the "Programs" tab of Task Manager select "explorer.exe" > "End Task" button.

OR

Start Menu > press Ctrl + Shift > Right-Click in an empty area of the Start menu.
A hidden menu will show.
Click "Exit Explorer"

You will be left with an empty screen but Windows and the applications should still be open.

Ctrl+Alt+Del (or Ctrl+Shift+Esc) to open Task Manager.
File Menu > "New Task (Run...)" > type "explorer" > click OK.
Windows Explorer should restart and display your desktop again.

There is a setting for Windows Explorer where Windows is instructed to "Launch folder windows in a separate process", and this tick box is under the "view" tab of the dialog shown via Control Panel > Folder Options or Windows Explorer "tools" menu > Folder Options.  The intention is that if one Windows Explorer instance freezes up, the other Windows Explorer instances are kept separate and should not be affected.  If enabled, this can prevent you from completely closing Windows Explorer using the steps above, but I also think that this setting may be partly responsible for causing leftover screen artefacts IF the other fancy visual "fade" effects are also enabled.  Test by enabling and disabling this "Launch folder windows in a separate process" setting.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BillDLCommented:
Thank you DrDamnit.
0
DrDamnitAuthor Commented:
You're welcome. Excellent post.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.