Cisco Router 867VAE-K9 Setup – DSL PPPOE

I have a CISCO 867VAE-K9 router running on IOS version 15.1. I have setup the PPP settings and tested that and it works, I able to ping the ISP DNS servers and also check the diagnostic for a successful ppp connection. The problem is with the internal routing, the router has an internal 5 LAN Ports, and when I connect a device on it, I can’t ping the router (gateway). Here is what I get when I run an interface brief:

Interface            IP-Address        OK?      Method Status   Protocol

ATM0    unassigned        YES     NVRAM            down     down
“This is ok it comes up when I connect the DSL”
Dialer1  unassigned        YES     NVRAM            up         up
Ethernet0          xx.xx.xx.xxx     YES     NVRAM            down     down  
“Don’t know why it’s DOWN this is probably the root error”
FastEthernet0    unassigned        YES     unset    down     down
FastEthernet1    unassigned        YES     unset    down     down
FastEthernet2    unassigned        YES     unset    down     down
FastEthernet3    unassigned        YES     unset    down     down
GigabitEthernet0            unassigned        YES     unset    down     down
GigabitEthernet1            unassigned        YES     NVRAM            administratively  down     down
NVI0     unassigned        YES     unset    administratively  down     down
Vlan1    unassigned        YES     unset    down     down

Here is my Config (again the PPP settings are working), please take a look and let me if you can see what am missing here, it seems to me like a routing issue. The goal is to have FastEthernet0 communicate out to the internet but right now it can not even pint the router (Ethernet0) maybe I need a VLAN but I don’t know:

Note: The Public IP is a random IP not an actual IP but the Netmask is correct

version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
wan mode dsl
no ipv6 cef
ip source-route
ip cef
!
vpdn enable
vpdn multihop
!
vpdn-group pppoe
!
controller VDSL 0
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface Ethernet0
 ip address 95.41.33.254 255.255.255.248
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface GigabitEthernet0
 no ip address
!
interface GigabitEthernet1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 ppp chap hostname xxxxxxxxx@att.net
 ppp chap password 0 xxxxxx
 ppp pap sent-username xxxxxxxx@att.net password 0 xxxxxx
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat pool pool1 95.41.33.248 95.41.33.255 netmask 255.255.255.248
ip nat inside source list 1 pool pool1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 95.41.33.248 0.0.0.7
OCSLosAngelesITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steven CarnahanNetwork ManagerCommented:
You need to assign an IP address to FastEthernet0


!
interface FastEthernet0
 no ip address
!


!
interface FastEthernet0
 ip address 95.41.33.xxx 255.255.255.248
!
0
Craig BeckCommented:
The Ethernet interface binds to the DSL interface when using VDSL, so that is where your WAN IP address is applied.  Therefore that configuration is incorrect in this case.

However you've got a couple of issues.

1] The Ethernet interface is only used for VDSL.  You're using ADSL here (that's what the config tells me) so you don't need an IP address on the Ethernet0 interface.  When using DSL the FastEthernet ports can't be used as WAN interfaces.

You need something like this (I've omitted what you've already got which is correct)...

service dhcp
ip dhcp excluded-address 192.168.0.1
ip dhcp pool LAN
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 8.8.8.8 8.8.4.4
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
!
ip access-list extended NAT
 permit ip 192.168.0.0 0.0.0.255 any
!
ip nat inside source list NAT interface Dialer1 overload
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Management

From novice to tech pro — start learning today.