JBoss 6.1 server adapter

Hi,

I was trying to download JBossAS Tools by clicking 'download additional server adapters'


i am getting below error

Cannot complete the install because of a conflicting dependency.
  Software being installed: JBossAS Tools 2.4.1.Final-v20130327-0617-B80 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.1.Final-v20130327-0617-B80)
  Software currently installed: JBossAS Tools 2.4.0.Final-v20121205-2029-B41 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.0.Final-v20121205-2029-B41)
  Only one of the following can be installed at once:
    WTP Overrides Core 2.4.0.Final-v20121205-2029-B41 (org.jboss.ide.eclipse.as.wtp.core 2.4.0.Final-v20121205-2029-B41)
    WTP Overrides Core 2.4.1.Final-v20130327-0617-B80 (org.jboss.ide.eclipse.as.wtp.core 2.4.1.Final-v20130327-0617-B80)
  Cannot satisfy dependency:
    From: JBossAS Tools 2.4.0.Final-v20121205-2029-B41 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.0.Final-v20121205-2029-B41)
    To: org.jboss.ide.eclipse.as.serverAdapter.wtp.feature.feature.group [2.4.0.Final-v20121205-2029-B41]
  Cannot satisfy dependency:
    From: JBossAS Tools 2.4.1.Final-v20130327-0617-B80 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.1.Final-v20130327-0617-B80)
    To: org.jboss.ide.eclipse.as.serverAdapter.wtp.feature.feature.group [2.4.1.Final-v20130327-0617-B80]
  Cannot satisfy dependency:
    From: JBossAS Tools Server Adapter 2.4.0.Final-v20121205-2029-B41 (org.jboss.ide.eclipse.as.serverAdapter.wtp.feature.feature.group 2.4.0.Final-v20121205-2029-B41)
    To: org.jboss.ide.eclipse.as.wtp.core [2.4.0.Final-v20121205-2029-B41]
  Cannot satisfy dependency:
    From: JBossAS Tools Server Adapter 2.4.1.Final-v20130327-0617-B80 (org.jboss.ide.eclipse.as.serverAdapter.wtp.feature.feature.group 2.4.1.Final-v20130327-0617-B80)
    To: org.jboss.ide.eclipse.as.wtp.core [2.4.1.Final-v20130327-0617-B80]


when i click 'New Runtimes' i see 'JBoss' as well as ' JBoss Community'.

What is the difference between above two. under ' JBoss Community' i see jboss 6.x runtime can i use that one for jboss 6.1.



please advise
Any links resources ideas highly appreciated. Thanks in advance
JBossAdapterError.jpg
JBossRuntime.jpg
LVL 7
gudii9Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

girionisCommented:
JBoss tools support the development of several jboss projects (hibernate, seam, drools, etc). But they are not always compatible with the eclipse versions.

From the error you posted you're trying to install two different versions of the same tool, which you cannot do. You better uninstall one before you install the other.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gudii9Author Commented:
i just clicked the link 'Download additional server adapter' as in the attachment 'JBossAdapterError'.. Not sure how to install single version separately and find which are two are belongs to same tool but different version to uninstall. please advise
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java EE

From novice to tech pro — start learning today.