Citrix XenApp 6.5 - End User Regional Settings

Hi Guys

I have an interesting scenario that I need some assistance with.

The long and short of it is that I have a payroll application that I'm trying to virtualise into Citrix XenApp 6.5 as a published application. I have successfully installed the client onto a Citrix Server with the relevant connectors, and have relocated its associated SQL DB's etc. That side of things definitely works.

The issue is when a payroll officer accesses the Citrix version of the application, the dates are around the wrong way. Basically, the dates are in US format, when we are in Australia.

To give you as much information as I can in regards to what I have tried so far, plus some insight on our environment, I will try to flesh out some details as best as I can.

Operating System:

* Windows Server 2008 R2 SP1
* 20+ servers in the XenApp 6.5 Farm

Citrix Configuration:

* 4 servers utilised as published desktop servers
* 4 servers utilised as published application servers
* 3 test servers
* 2 zone data collectors

Active Directory:

* Windows Server 2003 mixed mode (we have two 2003 servers remaining, so can't raise the functional level yet)
* OU's have been created with specific group policies targeting the relevant servers in those OU's
* Development/Production/Development/Test servers have different policies to cater for their needs

Disk Images:

* Provisioning Services 6.1
* Two Provisioning Services servers for production and one that is shared among test and development
* Separate Images for Published Applications and for Published Desktop

Virtualisation/Storage Array:

* All servers are virtualised on Citrix XenServer 6.1 with all updates upto date
* All servers using shared storage on an EMC VNX 5300 SAN

Original Conception:

* In order to virtualise the application, I took a copy of the existing image for Published Application as I don't need a separate server for this one application
* Image placed into Private Mode (read/write), into a server with no GP.
* Relevant packages installed, successfully and tested by the end user.
* Whilst in Private Mode, set regional settings successfully as well as timezone etc.
* Sealed the image, and powered back up as Shared Mode, but found that the regional settings had reverted back to the US.
* Checked an existing Desktop Image that is in Shared Mode, and the regional settings are correct
* Powered down a Desktop Image that was correct, and mounted the new image to this server. Checked the regional settings and it was incorrect.

 By mounting the image I'm having issues with onto a server that was working fine, and still having it revert the regional settings to the US, leads me to believe that these settings are not GPO based (or GPP) but something inside the image itself.

Would anyone have any ideas on how to fix this? The having the date format around the correct way for Australia is critical as this is a payroll application and having it wrong would be a disaster if we let it go unchecked.
Who is Participating?
lindentoConnect With a Mentor Commented:
What we normally find is that the local regional settings usually are the issue when anything is not correct with the regional settings inside a citrix session. You might want to check the regional settings on the client and have the user login on a different client. If the issue persists only for this user, you might also consider rebuilding the windows profile.
Please check your Default Domain Policy, most likely the computer section.
ben_delbridgeAuthor Commented:
I have checked this, and there is nothing in there relating to regional settings. One other thing worth noting, is that the servers in the Citrix Farm in question are in separate OU's, and inheritance on those OU's are disabled. So in saying that, they are not getting the Default Domain Policy anyway. There are other Citrix servers that don't have the regional settings issue that I am trying to solve
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

ben_delbridgeAuthor Commented:
Any further suggestions please..
Might there be a server local setting in place?  Run gpedit.msc and look at the local policies.

Lastly, try running  an RSoP.
ben_delbridgeAuthor Commented:
Thanks for your suggestion. I'll have a look at each setting and let you know what I find. Its a bit of a needle in a haystack :)
ben_delbridgeAuthor Commented:
Thanks for the suggestion.

Could it be the Default User or All Users profile inside the image being corrupt in some way?

Do you know if it is possible to repair it so that new sessions get the correct regional settings?
lindentoConnect With a Mentor Commented:
If you log in as a administrator user and open up regional settings in the control panel you can access an administrative tab which allows you to write the current regional settings to system account and the default user profile. This should repair any inconsistancies in regards to regional settings.
Please be aware i haven't worked with provisioning services though.
ben_delbridgeAuthor Commented:
I've found the issue. I needed to sign in as an Administrator, set the regional settings as desired, then write that back to the all users/default profile. I also had to delete any profiles that had logged onto that box before the changes, as they use what is already set in the profile before the changes to the default profile was made.
ben_delbridgeAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for ben_delbridge's comment #a39649853

for the following reason:

Found it myself as I was inadvertently using two accounts and getting different results.

as ben_delbridge postet he used a method described in my post 39589419 to solve the issue, but he did not award points at least for an assist.

Best Regards
ben_delbridgeAuthor Commented:
How do I award points?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.