Citrix receiver asks for installation when already installed

We have a user who is trying to log in to citrix web portal. The user is asked to install citrix receiver even though the same version is already installed. This happens only for a few users. No other users have any problems. No changes has been made to citrix and no citrix hotfixes has been applied lately. Though we did patch the windows OS, but that should not affect citrix and if so all users would be affected, not just a few.

Tried using the receiver cleanup tool, but the problem persists. What can be done? Delete the users profile in the windows client computer?
i486dx266Senior DevOps ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JLead Technical ArchitectCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.