Link to home
Create AccountLog in
Avatar of CHI-LTD
CHI-LTDFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Exchange Shell Command?

To enable an active sync device that has been blocked by a rule is?

Something:  -AllowNonProvisionableDevices $true

Thanks
SOLUTION
Avatar of Patrick Bogers
Patrick Bogers
Flag of Netherlands image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of CHI-LTD

ASKER

i have the deviceid..
Avatar of CHI-LTD

ASKER

This has changed it to allowed..

Set-CASMailbox Mailbox -ActiveSyncALlowedDeviceIDs $null

Any ideas why this has changed from allowed to blocked, and have not had any email?
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of CHI-LTD

ASKER

Managed to get it allowed.  Device StateReason was Polic, when blocked.  
Now its enabled, reason, is an individual..
How long to wait?
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of CHI-LTD

ASKER

Yes its allowed.

Still can't sync the device though!!!
Try removing and re-adding the account in device..
Avatar of CHI-LTD

ASKER

removed device from exchange
remotely wiped the device using maas app.
reconfigured activesync through maas, but failed....

Not showing in exchange or any issues in maas portal...
Do you have any TMG or anything else to publish the ActiveSync?
Avatar of CHI-LTD

ASKER

nope.  just firewall, ports open.
Only thing can delay this configuration is IIS cache (max 15 min).. just wait for some more time and see...

Meantime make sure the device ID which you allowed and the device you configuring is matching.. :-)
Avatar of CHI-LTD

ASKER

sure is matching by device id on exchange and maas360 and OWA...
Do you still have problem?

If yes..

Does the deviceID still shows under ActiveSyncAllowedDeviceIDs when you run the following command?
Get-CASMailbox <User> | FL ACtive*

Is there any device under blockedDeviceIDs?

What is the error when you try to activate the device?
Avatar of CHI-LTD

ASKER

Well its now started syncing this morning, and reliably when i hit refresh... failed once with 'could not connect due to security error...'
will update you monday.
thanks
Avatar of CHI-LTD

ASKER

We seem to be ok now, was an issue with our cloud MDM solution blocking the active sync device..