• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1436
  • Last Modified:

Trouble Adding ROMs in GroovyArcade

I don't know if any of you have experience with GroovyArcade, but hopefully someone's heard of it. It's an all-inclusive Linux live CD designed for emulating old game systems and arcades, based on Arch Linux and running a version of MAME. I recently installed GroovyArcade to the hard drive of an old Intel Mac Mini I have, and I'm having trouble installing my own ROMs. The ones that came built-in work, it just doesn't recognize the ones I add.

I'm able to successfully FTP into the machine, upload the ROM to the /home/roms/roms folder and the snapshot to the /home/roms/snaps folder, and give each the correct permissions (777) and group (arcade) to match the other ROMs and snapshots in those folders. But when I then load up AdvmenuPLUS it fails to recognize the ROM and thus the game cannot be played. I've tried adding the /home/roms/roms folder as a ROM path, rebooting, and repeating the process with multiple different ROMs (galagamf, galagamw, and galagao), but nothing seems to work. Googling, searching and posting in the GroovyMAME forums, and combing through the file system have turned up nothing useful so far. As I installed GroovyArcade natively on the hard drive instead of just on a USB flash drive, the USB installation guide's suggestion to add the ROM path wasn't very useful either as it's installed directly to the drive.

The interesting part is that when I adjust the filter to show uninstalled games and locate the greyed out Galaga selection (the game I'm trying to add), the selection successfully displays the snapshot I uploaded. So clearly the snapshot is being recognized correctly, but I'm still not sure why the ROMs aren't.

I'm sure I'm missing something simple, but I have no idea what. Any help would be greatly appreciated.
0
neilticktin
Asked:
neilticktin
1 Solution
 
☠ MASQ ☠Commented:
If you've got the file location for the ROMs sorted out have you checked the ROM formats of your new files are OK? Try CMPro to check the files.

Do you have a Windows install you could put a MAME into?  Just to check that both the GA bundled games and your own run OK.
0
 
neilticktinAuthor Commented:
I had trouble using CMPro, and having to use Windows in a VM to run it didn't make it any easier, but the idea was key. Someone on the GroovyMAME forums showed me a way to achieve the same goal with a tool already built into GroovyArcade. Turned out the ROMs that weren't working were simply incomplete. Some were missing BIOS files I was able to find and insert into the ROM (which now work), and some were just missing core files and needed to be replaced.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now