Exchange Server Certificate disabled by install of WD My Book Live setup

I purchased a Western Digital external drive (My Book Live) to use to backup my SBS 2011 server. I ran the My Book Live setup as instructed and all went well but found shortly thereafter that this setup installed a new certificate that disabled my Exchange mail certificate and now everyone is getting this error:

"There is a problem with the proxy server's security certificate. The name on the security certificate is invalid or does not match the name on the target siite ..."

I can view the certificate and I see that the certificate is intended for "All application policies" and is issued to "*.device702688.wd2go.com". It was issued by "remotewd.com" and is valid from 8/30/2013 (the day I installed) to 8/30/2023.

I cannot find the certificate on my exchange server anywhere.

I have a support case in with WD and will contact them in the morning but I thought I would reach out here first to see if anyone has a suggestion.
LVL 2
bbaldwinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

R. Andrew KoffronCommented:
if you have a paid certificate, you should just be able to use the SBS2011 wizard and reinstall it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sushil SonawaneCommented:
Bind your old certificate in IIS to resolve the issue.

To bind the certificate refer below link:

http://www.iis.net/learn/manage/configuring-security/how-to-set-up-ssl-on-iis
http://www.digicert.com/ssl-certificate-installation-microsoft-iis-7.htm
http://www.sslshopper.com/article-installing-an-ssl-certificate-in-windows-server-2008-iis-7.0.html


Or

Just reenable the old certificate through Exchange shell and assign services "smtp,iis,pop3," to certificate it will automatically overwrite your WD certificate.
0
SreRajCommented:
Hi,

If you can see Exchange Certificates in Certificates console Personal Store for local machine, then you can Enable the certificates using Enable-ExchangeCertificate cmdlet from Exchange Management Shell. Please refer following article for more information.

http://technet.microsoft.com/en-us/library/aa997231(v=exchg.141).aspx
0
bbaldwinAuthor Commented:
I noticed in the Exchange console that there are valid and invalid certificates there. Do I need to clear these out and reinstall my certificate that I have from GoDaddy?
0
Simon Butler (Sembee)ConsultantCommented:
As this is SBS, run the wizard to add a trusted SSL certificate from the management console. When you get the choice, choose the option to install one that already exists and select the one from GoDaddy. That should correct the problems for you.

Simon.
0
bbaldwinAuthor Commented:
Simon,

Thanks for your suggestion. I get an error when running the wizard that says "The imported certificate does not match your website. Verify that you have selected the correct certificate and try again."

Frustrated!!

Bob
0
bbaldwinAuthor Commented:
And actually when I view the certificate, it is the correct certificate. I cannot find the wd.com cert on my server. Very confused.
0
Simon Butler (Sembee)ConsultantCommented:
If you browse to https://remote.example.com/owa do you get the OWA login page?
Did you setup the server with the wizards, including the wizard that sets the host name as remote.example.com or was the server configured "manually"?

Simon.
0
bbaldwinAuthor Commented:
ok, we figured it out!! The My Book Live has a Linux OS and because my router UPnP (Universal Plug and Play) enabled, the My Book Live took over port 80 and 443 and all traffic was going to it and not to my server. Thank you all for your help!
0
bbaldwinAuthor Commented:
All I had to do was turn off the My Book Live and wait a few minutes and all was well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.