Database dismounted due to size

I have exchange 2007 all in one role and my database is dismounted everyday. and found the below event.  I can follow the http://technet.microsoft.com/en-us/library/bb232092(EXCHG.80).aspx , but as per the link, the default size is 50GB, but my database size is now 250 GB and not it started the errors. Can I follow the link and put 300GB

Exchange store 'First Storage Group\': The current physical size of this database (the .edb file) is 251 GB. This database has exceeded the size limit of 250 GB. However, the logical free space in this database has not yet been evaluated. Therefore, it is possible that this database contains enough free space to bring its logical size below the maximum size limit.

Thanks
kolathaya123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vijaya Babu SekarAssociate Ops ManagerCommented:
Better you can split the database that means you can create new mailbox database store and move the mailbox from affected mailbox database to new mailbox database. once you move all the mailbox from old to new. you can take backup of old DB and delete it. it is permanent solution for your organization.

Because if increased the DB size , it will be creating problem like slowness, hanging. etc

Thanks.
0
N-WCommented:
Can I follow the link and put 300GB
Yes, you can. Although the default limit is 50GB per database for Exchange 2007 Standard, you can set the limit to anything up to 16TB (Microsoft calls this "unlimited" for some reason).

Follow the link and after modifying the registry key, restart the Microsoft Exchange Information Store service.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kolathaya123Author Commented:
Thanks N-W,

But default the database must dismounted when database reached 50GB, but it started when it reached 250GB. There is no registry settings in that place for 250GB. Something unusual..

Thanks
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

SreRajCommented:
Hi,

If you have plenty of free space in the disk, then you can go ahead and increase the limit. You can run the command ESEUTIL /MS to see how much whitespace is there in the database. ESEUTIL requires database to be offline while running this command. Also, you can use it to run an offline defragmentation which will help to shrink the database file, but at the cost of down time to complete the defragmentation.
0
N-WCommented:
You're welcome.

If you running Exchange 2007 SP1 or above, the default limit will be 250GB, not 50GB. In this case, there won't be a default registry key. You'll need to add the registry key to allow it to grow past the 250GB mark.
0
Sushil SonawaneCommented:
Make sure your exchange server update with latest service pack. As you mention in you can create the registry key and set the value 300 GB to resolve the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.