Sybase ASE 15.7 do not know datepart function

Hello Experts,

I have Sybase ASE 15.7 install on my Solaris 10 SPARC. I tried to use function datepart in SQL interactive but seems ASE do not know this function as text hilighter color black. please see attach picture for reference. Is there anyway to integrate this function to my current ASE? I tried googling around but no answer there.

Thank you.
syb.PNG
trazodoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jan FranekCommented:
Did you try to actually use the function ? What error message did you get ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
trazodoneAuthor Commented:
Hi,

I tried to recoding again it was just syntax error. Now I know that Sybase ASE 15.7 supports this function.

Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Sybase Database

From novice to tech pro — start learning today.