Avatar of bergquistcompany
bergquistcompany asked on

Office 365 Hybrid with Outlook 2010 can't automatically setup outlook search fails

Hello EE,

We have the following:

                                                     Root Domain
Child User domain Northamerica                       Child User domain Overseas
Currently when setting up Outlook 2010 in configuring email server settings
1. Establish network connection - green check
2. Search for email@bergquistcompany.com server settings - problem connecting to server

Autodiscover tests fine and this is only for the overseas users.  All Northamerica users work fine.  The only way around this is manually configuring Outlook.  There must be a way to resolve it for these users?
Microsoft 365OutlookMicrosoft Office

Avatar of undefined
Last Comment
bergquistcompany

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Vasil Michev (MVP)

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
bergquistcompany

See attached for Outlook results

If I use the users credentials from my workstation, I get:
      Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
       The Microsoft Connectivity Analyzer successfully retrieved Autodiscover settings by sending an Autodiscover POST.
       
      Test Steps
       
      The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://pod51038.outlook.com/Autodiscover/Autodiscover.xml for user GraceC@tbqc.mail.onmicrosoft.com.
       The Autodiscover XML response was successfully retrieved.
       
      Additional Details
       Autodiscover Account Settings
XML response:
<?xml version="1.0"?>
<Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
<User>
<DisplayName>Chan, Grace</DisplayName>
<LegacyDN>/o=ExchangeLabs/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=31bab3aba16c44c4bddc00e07edfac29-Chan, Grace</LegacyDN>
<DeploymentId>1319c81a-79a2-4a22-b833-fb697e950ead</DeploymentId>
</User>
<Account>
<AccountType>email</AccountType>
<Action>settings</Action>
<Protocol>
<Type>EXCH</Type>
<Server>20c9d77c-5832-4244-b71c-da13134332ee@bergquistcompany.com</Server>
<ServerDN>/o=ExchangeLabs/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=20c9d77c-5832-4244-b71c-da13134332ee@bergquistcompany.com</ServerDN>
<ServerVersion>73C082E9</ServerVersion>
<MdbDN>/o=ExchangeLabs/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=20c9d77c-5832-4244-b71c-da13134332ee@bergquistcompany.com/cn=Microsoft Private MDB</MdbDN>
<ASUrl>https://outlook.office365.com/EWS/Exchange.asmx</ASUrl>
<OOFUrl>https://outlook.office365.com/EWS/Exchange.asmx</OOFUrl>
<OABUrl>https://outlook.office365.com/OAB/bffbef90-82fa-4f63-9994-4b33f4ab4abe/</OABUrl>
<UMUrl>https://outlook.office365.com/EWS/UM2007Legacy.asmx</UMUrl>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<AuthPackage>Anonymous</AuthPackage>
<PublicFolderServer>outlook.office365.com</PublicFolderServer>
<EwsUrl>https://outlook.office365.com/EWS/Exchange.asmx</EwsUrl>
<EmwsUrl>https://outlook.office365.com/EWS/Exchange.asmx</EmwsUrl>
<SharingUrl>https://outlook.office365.com/EWS/Exchange.asmx</SharingUrl>
<EcpUrl>https://outlook.office365.com/ecp/</EcpUrl>
<EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-um>
<EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-aggr>
<EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=bergquistcompany.com</EcpUrl-mt>
<EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-ret>
<EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-sms>
<EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=bergquistcompany.com</EcpUrl-publish>
<EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-photo>
<EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tm>
<EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tmCreating>
<EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tmEditing>
<EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-extinstall>
<ServerExclusiveConnect>off</ServerExclusiveConnect>
</Protocol>
<Protocol>
<Type>EXPR</Type>
<Server>outlook.office365.com</Server>
<ASUrl>https://outlook.office365.com/EWS/Exchange.asmx</ASUrl>
<OOFUrl>https://outlook.office365.com/EWS/Exchange.asmx</OOFUrl>
<OABUrl>https://outlook.office365.com/OAB/bffbef90-82fa-4f63-9994-4b33f4ab4abe/</OABUrl>
<UMUrl>https://outlook.office365.com/EWS/UM2007Legacy.asmx</UMUrl>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<SSL>On</SSL>
<AuthPackage>Basic</AuthPackage>
<CertPrincipalName>msstd:outlook.com</CertPrincipalName>
<EwsUrl>https://outlook.office365.com/EWS/Exchange.asmx</EwsUrl>
<EmwsUrl>https://outlook.office365.com/EWS/Exchange.asmx</EmwsUrl>
<SharingUrl>https://outlook.office365.com/EWS/Exchange.asmx</SharingUrl>
<EcpUrl>https://outlook.office365.com/ecp/</EcpUrl>
<EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-um>
<EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-aggr>
<EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=bergquistcompany.com</EcpUrl-mt>
<EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-ret>
<EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-sms>
<EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=bergquistcompany.com</EcpUrl-publish>
<EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-photo>
<EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tm>
<EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tmCreating>
<EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-tmEditing>
<EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=bergquistcompany.com</EcpUrl-extinstall>
<ServerExclusiveConnect>on</ServerExclusiveConnect>
<EwsPartnerUrl>https://outlook.office365.com/EWS/Exchange.asmx</EwsPartnerUrl>
<GroupingInformation>BLUPR07</GroupingInformation>
</Protocol>
<Protocol>
<Type>WEB</Type>
<Port>0</Port>
<DirectoryPort>0</DirectoryPort>
<ReferralPort>0</ReferralPort>
<Internal>
<OWAUrl AuthenticationMethod="LiveIdFba">https://outlook.office365.com/owa/</OWAUrl>
<Protocol>
<Type>EXCH</Type>
<ASUrl>https://outlook.office365.com/EWS/Exchange.asmx</ASUrl>
</Protocol>
</Internal>
<External>
<OWAUrl AuthenticationMethod="Fba">https://outlook.office365.com/owa/bergquistcompany.com/</OWAUrl>
<Protocol>
<Type>EXPR</Type>
<ASUrl>https://outlook.office365.com/EWS/Exchange.asmx</ASUrl>
</Protocol>
</External>
</Protocol>
</Account>
</Response>
</Autodiscover>
ASKER
bergquistcompany

This may help.  From the exact same machine if I join the northamerica domain I can automatically configure Outlook

If i rejoin it to bqasia domain and try I get the error that there is a problem with the server settings

This leaves me to believe a domain issue?
Vasil Michev (MVP)

Probably policy related one, as I mentioned if you have folder redirection for the App Data folder, Outlook 2010 will give you some trouble. Outlook 2013 should work fine.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
ASKER
bergquistcompany

Unfortunately I need to be on 2010 for the near future.  From what I can tell from the second child domain it is not redirecting to the proper @tbqc.onmicrosoft.com where from the first child domain it is
ASKER
bergquistcompany

Thanks for getting me on the right track.  Turns out redirecting was not working so had to modify that child domain so it would redirect online but running the autoconnectivity test helped