IIS virtual directory unable to access Synology NAS

I have Windows 7 Ultimate and a Synology 1512+ Diskstation NAS.

Using windows explorer, i can access the NAS using  \\diskstation\myFolders

In IIS, under my 'Default Web site', I have a website called  'myWebsite01'
I can create a virtual directory under myWebsite01, but I'm unable to get the virtual directory to successfully point to the NAS.

I haven't had any luck finding a complete solution online.
Could someone show me a step by step guide?

Thank you for your help.
Ron
ron2468Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
IIS won't allow you to access a virtual directory on another machine.  The 'user' that IIS runs as does not have permission or a login to another machine.  It is restricted to the machine it is on.  Apache operates the same way.
0
Patrick BogersDatacenter platform engineer LindowsCommented:
I disagree with DaveBaldwin, i have several virtual directories in IIS pointing to other machines but authentication can be tricky.

Start -> execute and type   \\<name or ipaddress for the NAS>   and press enter
Are there any shares to be seen? If yes find in security which user has access to this share and configure you vDir with this credentials. It also helps to have the application pool adjusted to network services allowing the website to crawl network resources.

No share on the NAS? create one.
0
ron2468Author Commented:
Hi Patrick,

If I understand you correctly, yes, there is a share on the NAS because i can access it by typing \\diskstation in windows explorer, and i can see the files on the NAS.

When I right click on this Network share (\\diskstation) i can see that I have permission to access it, as I'm the administrator on the this PC.

Under IIS, I haven't been able to successfully establish a connection to the share using my administrator username and password.  When i Test Settings, I get an error, and when i run the website, i get an error in the browser.

See the attached pics.
Add-Virtual-Directory.png
Test-Settings.png
Server-Error.png
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

In Add-Virtual-Directory.png you 'see' what is wrong.
Under 'connect as' there should be entered valid credentials the NAS understands.
The login can be something as username@nasadress or  ..\nasuser          try some.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ron2468Author Commented:
Sorry, its not working.  I've tried all combos.  There are no credentials that doesn't give me an error.
0
PrecedenceCommented:
Any fix for this yet? I'm having same issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.