Certreq error on Windows 2003

I installed CA on a Windows 2003 SP3 server.

I am following the instructions at http://support.microsoft.com/kb/321051 and it doesn't work.

I copied the text in Step1 and pasted into Notepad.  I changed the subject to "myserver.mydomain.local", saved the file as request.inf and used certreq ( the way they said too, "certreq -new request.inf request.req") to turn it into a req file.

(I also tried "CN=myserver, DC=mydomain, DC=local". Not sure which format to use. Does it matter?)

Next, I open CA and right-click on my server, all tasks, submit new request. When I pick that req file I get this error:

The request contains no certificate template information. 0x80094801 (-2146875391). Denied by policy module 0x80094801. The request does not contain a certificate template extension or the certificate template request attribute.
Since I followed the instructions on Microsoft's site, I assume that they put in the template information in the request.inf file in their example.  So that makes me wonder if there is something wrong with my CA.

I have never worked with the contents of certificates before.  I usually buy them from a vendor and don't have to deal with this.  Any help is greatly appreciated.
Who is Participating?
jekautzAuthor Commented:
I uninstalled my Enterprise CA and reinstalled a Standalone Root CA.  I was then able to submit my request.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.