USB hard drive does not display drive letter

USB hard drive does not display a drive letter.  It shows up within device manager but does not show in my computer or disk management.

The machine with the issue is a windows 2008 sbs server - The hard drives work fine on other computers.  If I reboot the server, the drive appears with a drive letter.  Its not convenient to keep restarting the server - 60 users connect to the server for file sharing.
resolver1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

James CookIT ManagerCommented:
Have you got any mapped network drives?
They can often use the drive letter that would normally be assigned to the USB drive.

This can be managed in
control panel > administrative tools > computer management > storage > disk management.
0
resolver1Author Commented:
Thanks for your reply.  No mapped network drives on this computer.
0
John-Charles-HerzbergCommented:
This is for Windows Server 2003 but might help.

Windows Server Enterprise and DataCenter Edition do not assign drive letters to new fixed drives (USB and Firewire disks are usually 'fixed'). This is up to the administrator because otherwise SAN (Storage Area Network) drives might be mounted accidentally.

This feature is called AutoMount and can be enabled by means of the DiskPart tool:

Open a command prompt, enter diskpart, on the DiskPart prompt enter automount to see the current state or automount enable to enable it.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

resolver1Author Commented:
Automount is enabled.  Other USB hard drives are OK.  It seams to be "western digital" hard drives that are causing us issues.  This only started happening since Friday.  

Keep the suggestions coming
0
Thomas GrassiSystems AdministratorCommented:
Sounds like the usb drive has a conflict with another devices drive letter that is why it does not show it.

Did this USB drive ever work on the SBS 2008 server? If so then it is retaining the drive letter.

What other USB drives are connected to the SBS 2008 server?

How many internal drives do you have?

What drives letter do you need?

Can you assign a different drive letter to this usb drive?
0
David AtkinTechnical DirectorCommented:
Hello,

Why are you sharing your files on a USB drive anyway?  The ideal thing to do here would be to install some additional internal drives and have the file sharing done of that.

If you haven't already, change the USB Cable and another USB port.

You could try assigning the drive with another drive letter that is higher in the alphabet so that it doesn't get used by other drives.
0
resolver1Author Commented:
The hard drive is used backup files/exchange and SharePoint through the backup exec software.

Previously to Friday the drive letter was Q and worked fine.  We have no mapped network drivers on the computer with the problem.  I've written answers to each of your questions:

What other USB drives are connected to the SBS 2008 server?  Hiatachi drives work fine.  

How many internal drives do you have? We have one RAID system.

What drives letter do you need? Just Q drive.  

Can you assign a different drive letter to this usb drive?  no because we cant see the device in disk manager.  

Why are you sharing your files on a USB drive anyway?  We dont share anything on our usb drives.  The server RAID drives are used for this, i cant reboot the server because the server also has exchange/file shares/share point

If you haven't already, change the USB Cable and another USB port.  -  Already tried it.  If I restarted the server with the same hard drive and cable, the Hard drive would appear as a drive letter.  

You could try assigning the drive with another drive letter that is higher in the alphabet so that it doesn't get used by other drives.  --  i cant assign another drive latter as the Hard drive doesnt show in disk management.
0
Thomas GrassiSystems AdministratorCommented:
You have other usb drives attached have you tried to remove them and then plug in the USB drive that you are having the problem with?

When you plug the drive in to you see the usb adding device message in lower right corner?

Have you looked in device manager to see if anything is added?

Leave device manager open then plug drive in see if you notice any changes.

You say it works after you restart the server. If the Drive plugged in or do you plug it in right after restart
0
resolver1Author Commented:
I've replied to each of your questions again:

You have other USB drives attached have you tried to remove them and then plug in the USB drive that you are having the problem with?  Other makes work fine when unplugged and re-plugged in.  Its just the western digital drives with the issue.  

When you plug the drive in you see the USB adding device message in lower right corner?  See picture - drive appears without a letter.

Have you looked in device manager to see if anything is added? The drive shows under device manager but when properties of the drive is opened and populate under the volume tab is clicked I receive the message "volume information for this disk cannon be found".  If the same operation is performed under other drives it will show the drive information.  

You say it works after you restart the server. If the Drive plugged in or do you plug it in right after restart?  The drive is plugged in before the system is rebooted and a drive letter appears (We don't unplug it until we have a backup)
USB-Drives-with-no-letter.jpg
0
David AtkinTechnical DirectorCommented:
Have any updates been installed recentlythat could cause the issue?

Just to confirm, do you have multiple western digital drives for the backups?  If so does it happen with them all?

Also, do you have any disk errors/warnings in the logs?
0
James CookIT ManagerCommented:
maybe unistall the driver from device manager?
Right-click > uninstall. then either hit 'scan for hardware changes' or unplug/replug in.
0
resolver1Author Commented:
Have any updates been installed recently that could cause the issue?  It worked Thursday

Just to confirm, do you have multiple western digital drives for the backups?  If so does it happen with them all?  yes, the problem happens on each of the western digital drives.

Also, do you have any disk errors/warnings in the logs? Plugged in the drive and checked event viewer and device appear with a status 0 which states the drive was detected sucsessfull: see http://technet.microsoft.com/en-us/library/cc756321(v=ws.10).aspx.  What other logs would i look at?
0
resolver1Author Commented:
In answer to your questions:

Maybe uninstall the driver from device manager? Already uninstalled the driver and re-detected and it still doesn't appear with a drive letter.

Sorry i didnt answer your question in full Scorpeo:  Have any updates been installed recently that could cause the issue?  It worked Thursday.  A driver was installed on the Friday for our monthly backup drive (which is also western digital) so that could be the problem....  

Our daily backup drive which is the one with the issue now is : My Passport Essential SE (USB 3.0)  - http://support.wdc.com/product/download.asp?groupid=215&lang=en
Our monthly drive is a http://support.wdc.com/product/download.asp?groupid=304&lang=en
0
David AtkinTechnical DirectorCommented:
A driver was installed on the Friday for our monthly backup drive (which is also western digital) so that could be the problem....  

Roll back the driver if possible
0
resolver1Author Commented:
No roll back option. Looks like it didn't update the driver for the backup daily hard drive.
0
Thomas GrassiSystems AdministratorCommented:
Have you tried this?

Remove all usb drives from server restart server without any usb drives.

Now plug in the usb drives you are having problem with.

Do they show up with a drive now? If so go to disk manager and set them to the drive you want them to be.

Next remove them and then plug them back in see if they retain the drive letter you want.

If they do then plug in the remaining usb drives and go thru the same process.

See if that helps.
0
resolver1Author Commented:
I've now solved the issue.  I noticed Daily #2 was being detected so I checked the firmware version that was installed on it, it was 1.016 (previously 1.015) so I updated daily #2 and it now detects.
0
Thomas GrassiSystems AdministratorCommented:
Glad to see you have it working
0
resolver1Author Commented:
I spoke to soon.  There are a couple of issues going forward with this.  One every time we insert the USB hard drive it detects as "D:" even though we change this to our usual daily drive letter "Q:".  How can i make it default to "Q:" as soon as i plug it in?  

Symantec will automatically look for "Q" drive before backing up and if its not there, the backup will not occur.
0
Thomas GrassiSystems AdministratorCommented:
When you plug in the usb drive and it is drive letter D then just go to Computer Management then select disk management  in right bottom window you will see your drives listed
scroll down till you see the D Drive then highlight it. Once highlighted right click and select change drive letter Q if not listed then another device has that assignment.

After you click ok unplug the usb drive and then plug it back in it should now be Q Drive
0
resolver1Author Commented:
Un-plugged Daily #1 which was changed to "Q" last night and plugged back in and it appeared as "Q" again.  

Plugged the next days drive Daily #1 in the drive and it appeared as "D".  Changed to "Q" through disk manager.  Unplugged the drive and plugged it back in and it appeared as "Q" again.  

Plugged daily #1 in again and it appeared as "D".  It must be something to do with switching the drives.  Any ideas how we can resolve this?

Thanks for your help :-)
0
Thomas GrassiSystems AdministratorCommented:
Is Daily #2 still working?

I have noticed over the years that usb devices may not work as we like especially when we switch to new OS systems.

I had several usb drives that did not work well when I went to Windows 7

Can I ask why you are plugging them in and then removing them?
Is it possible to leave them connected all the time?
If it is the number of usb ports that is the problem I use a usb hub on my Windows 8 server works very well.
0
resolver1Author Commented:
Is Daily #2 still working?
   Both drives work (daily #1 and daily #2) but just show the wrong drive letter.

I have noticed over the years that USB devices may not work as we like especially when we switch to new OS systems.

I had several USB drives that did not work well when I went to Windows 7

Can I ask why you are plugging them in and then removing them?
  We backup our servers to external USB drives and take them off site.  We alternate each drive so we always have 1 drive off site.  

Is it possible to leave them connected all the time?
  no because we need the last nights backup off site incase of disaster recovery

If it is the number of usb ports that is the problem I use a usb hub on my Windows 8 server works very well.
  We have enough USB ports.
0
Thomas GrassiSystems AdministratorCommented:
I just tested on my windows 2008 server.
Took five usb drives assigned them all to drive Q unplugged each one several times all 5 always Q drive.

So how many drives to you have in total that is swapped?

If you take each one plug in and assign to drive Q then remove and plug back in what happens.

Try one at a time.

Do they always go to D ?
Is it possible to change the script to use D? I know that does not fix this but might resolve this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
resolver1Author Commented:
yeah, I've gone with using "D" as the default daily backup and changed the monthly which is usually "D" to "M".  

Thanks for your help guys.
0
resolver1Author Commented:
Thanks for all your help.  What a annoying problem, anyway i think we have a work around now :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.