Why does my WiFi speed suck?

I have two access points on the same floor (the main floor) of the house because on this floor I have my office, the kitchen, and my wifes office. One AP is in her office, and one is in mine. Thus, at NO TIME while on this floor of the house, are you EVER more than 30 feet from an access point. There may be one or more walls between you an the AP, but you're never more than 30 about feet.

Yet - despite this proximity to an AP, my speed consistently drops down below 54Mbps. Very usually reaching 6Mbps or even 1Mbps according to the laptop connection status indicator (Windows and Linux both confirm the speed) or our Android phones.

The AP's are g/n, and all my wireless devices are g/n. So I should have (at miniumum) 54Mbps, which would at least be OK for watching YouTube, but 6Mbps is just not cutting it.

I have tried several different types of APs, and since they all have the same effect I am starting to believe it is either user error, or my house is a Faraday cage.
Android link speed
LVL 32
DrDamnitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strivoliCommented:
Can you post a picture of the location of both APs? The picture should show the AP and the walls, ceiling, furniture located nearby, ...
0
Nick RhodeIT DirectorCommented:
I guess whats in the walls :O

If this has happened on more than 1 AP then most likely there is some sort of interference (EMI) in the house which is weakening your signal or you have brick walls.  If this is the same AP did you try maybe checking for a firmware upgrade?

My guess would be to move about the house and go from room to room with your wireless device and check the strength to see if you can narrow it down to a room and such.  Just move around like the verizon guy (can you hear me now), stand for little bit then move again.
0
bright12Commented:
Maybe a strange question, but do you have a weather station in house that use an outside measurement device? It can be that the batteries of that equipment are low, which may cause this problem.

Another question. What kind of walls do you have? Wood, stone or armed concrete?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Tony GiangrecoCommented:
Go into the access points and router and select a different channel. Normally 6 or 11 are the best.
0
Darr247Commented:
I would choose channels 1 and 11.
6 is the default most manufacturers use, so if there are other networks nearby the odds are high that 6 is already used by others (who never changed the channel).

Download and install inSSIDer and look for competing networks nearby... that will give you a good visual of how channels within 5 of each other step on each other's signal, too.
0
DrDamnitAuthor Commented:
1. Walls are drywall.
2. One AP is mounted to the wall near a printer, but nothing else. The other is on a table next to an iMac that sleeps like a lazy dog for 6 out of 7 days of the week.
3. All APs have the latest firmware.

I have just downloaded an app to my phone (WiFi Overview 360), which shows the signal strengths of the APs.

Channel 1 is the clearest channel, so I have changed the channel on both of them to 1.

Both have the same SSID (in the hopes that a device will roam from one to another as it finds better signals).

While 5 feet from the AP in my office, signal attinuation is -46dBm, and link speed is 65Mbps. Not what I wish I had, but certainly doable. Conversely, the AP at theother side of the house has an attenuation of -78 dBm. There is no link speed at the moment because I am not connected to it.

When I walk to the other side of the house, it appears that the phone I am using is properly switching APs because the connection drops, and then it connects to the closer AP with the better signal. When I return to my office, it switches again.

However, if I am in the middle of the house (a bedroom or the kitchen) the attenuation for BOTH APs drops to -72dBm to -85 dBm.

Could this be deconstructive interference?
0
Darr247Commented:
> (in the hopes that a device will roam from one
to another as it finds better signals).
That only works with WPA/WPA2-enterprise authentication... with pre-shared key (WPA/WPA2-PSK or 'personal'), when it changes connection from one station to another it connects and requests an IP address (most of the time it will even get the same IP address it had, but it will take 10-30 seconds for that transaction to occur, during which there will be no apparent connectivity)... with enterprise authentication (properly setup), it can pre-authenticate to approaching stations, and when the connection switches it keeps the same session, with hardly any interruption in service.

For maximum throughput they should be on different channels, otherwise they 'hear' each other and take turns talking, resulting in lower throughput (though it doesn't cause disconnects, like a nearby wireless network stepping on its signal could).
0
DrDamnitAuthor Commented:
I can handle the temporary drops at the moment. I have changed one AP's channel to 3 (another very available channel). I'll redo the measurements and report.
0
Tony GiangrecoCommented:
Here is a small utility I used at a client's factory to see where their wireless signal was strong and weak. It runs on a laptop and provides insight into your wireless strength.

http://www.passmark.com/products/wirelessmonitor.htm
0
Nick RhodeIT DirectorCommented:
Try having them on seperate channels otherwise it might be co-channel interference.  That might be your problem
0
Darr247Commented:
You should use only channels 1, 6 and 11 in the 2.4GHz band.
As I said in http:#a39464072 inSSIDer will show you graphically how the 2.4GHz frequencies step on adjacent channels. Much like this graphic demonstrates them:2.4GHz Frequency Map (click for larger)Note that channel 14 is available only in Japan and is restricted to 802.11b use. North and South Americas allow using only channels 1 through 11, so the possible non-overlapping channels amount to only three... if you use channel 3, anyone nearby that uses 1 or 6 (out of the typical 1, 6 or 11) will be stepping on your signal.
0
profgeekCommented:
Are your access points dual radio, e.g. does 802.11n run on 5 ghz while 802.11g is running on 2.4?  Or are you running both g and n on 2.4?  If you have dual radios, have you tried using 802.11n exclusively?
0
DrDamnitAuthor Commented:
OK... Access points are now running on channel 1 and 11.

profgeek: yes. Both were set to auto. I have now changed n to run on the 5Ghz band only. I still have a need to support g because older laptops that are occasionally used or friends who come over may have g, so that is on the 2.4 band.
0
profgeekCommented:
How is your throughput on the n band from various locations in the house?
0
DrDamnitAuthor Commented:
OK. I have made some changes, and it appears to have taken me back a step. I sit here in the kitchen 10 feet from the DAP-1522, it my phone (Samsung GS3 - has n NIC) doesn't see it. I figured out that was because the phone apparently cannot see channel 161 for 5Ghz. So, I have set it back to channel 36.

Other changes:
Changed the SSID for the 2.4Ghz g radio on the Cisco to "Series of gTubes' to differentiate it from the n, which is more important.
Changed both n radios to run on 40Mhz only.
5Ghz radios now run n only

The attinuation for the signal from the DAP-1522, whcih is ten feet from me is bouncing between -70 dBm to -85dBm, which obviously... stilll sucks. So much in fact, the phone dropped the WiFi connection and switched back to 4g.

Here are the current configs:
DAP-1522 Wireless configWRT610N Wireless Config
PS. Yes... I know the Cisco is a router. The WAN / red interface is not plugged into anything. I am only using the AP / switch side of it.
0
DrDamnitAuthor Commented:
Dar247:

I just now saw your recommendation for inSSIDer, which isa great app. Here are the screens from that:
Screenshot-2013-09-05-10-43-50.png
Screenshot-2013-09-05-10-44-23.png
Screenshot-2013-09-05-10-44-31.png
Screenshot-2013-09-05-10-44-41.png
0
Darr247Commented:
If you can set the DLink to a higher channel, it's possible it will automatically provide more gain. Here's a chart of the allowed power limits for the 5GHz band here in FCC land:U-NII (5GHz) Band Power Limits (click for larger)Note those are not to scale... 36dBm is actually 20x more gain than 23dBm.
0
DrDamnitAuthor Commented:
The d-link screenshot is deceptive. That's actually channel 161, not 16.
0
Darr247Commented:
The U-NII 2 band is typically required to use Dynamic Frequency Selection (DFS), to prevent interference with airport radar, by the way.
0
DrDamnitAuthor Commented:
OK. DLink is at channel 48, and Cisco is on 44.
0
DrDamnitAuthor Commented:
Here's how it looks now while in the kitchen (half way between the two AP's)

Network ScanAP Overlap
Thoughts?
0
Darr247Commented:
I think I'd go back to 149 and 161 with wide (40MHz) channels... though auto 20/40 should work fine, too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Craig BeckCommented:
If the issue here is because you're only getting a 6Mbps link-speed it's purely because you're not getting enough signal from the APs.

InSSIDer shows a signal around the -90dBm mark.  That's right on the edge of most data-rates' usable receive strength and will most likely not pass any data.

Using the UNII-3 band is intended to be used for outdoor point-to-point applications only.
0
DrDamnitAuthor Commented:
@Dar247:

These are my only options on the Cisco.
Dammit Cisco...
0
DrDamnitAuthor Commented:
The D-Link is better...
DLink Win
0
Craig BeckCommented:
I think the D-Link is showing more channels because you're not using 40MHz-only channels on that box (you're using 20 or 40).

That still doesn't change the fact that you're not getting enough signal from the APs.
0
DrDamnitAuthor Commented:
That still doesn't change the fact that you're not getting enough signal from the APs.

Do you think this is a power issue? I agree I am not getting enough signal. The question becomes: why? What can I do about it?
0
Craig BeckCommented:
Well, it is and it isn't.

A] Increasing the power 'could' get more signal to the client.
B] Changing the antennas 'could' get more signal to the client.

Increasing the power, or gain of the antennas, could help but if you need to increase the radiated power coming from the AP, you also need to do it for the client unless the client already puts out more power than the AP.

It's a two-way thing.  The AP talks to the client, and the client talks to the AP.  If you have to shout at someone to be heard but they only whisper back, you'll not hear what they said.

There is therefore a simple answer - add more APs.
0
DrDamnitAuthor Commented:
I am not disagreeing with you, and may (ultimately) add another AP. But the extreme proximity of these AP's to this room leaves me to think that there is something else going on.

How could an access point have so lower power from just 20-25 feet away with n signals, but g signals are nice and strong?

I also agree that the device (whether it is a phone or a laptop) must also be able to communicate back. But, if that was the issue, I would expect some devices to work and others to not work. Neither the phones (2 Samsung GS3s), nor my Lenovo laptop, nor my HP laptop, nor my wife's Macbook air show any improvement. Which is why I was thinking its either the APs or their configuration.

The walls to this room are not made of lead... and before I run another Cat5 cable and power to this room to run an AP, I wanted to make sure that I was configuring things correctly.

So far, I have gotten VERY good advice from everyone in this thread. Changing g to 20Mhz only and n to 40Mhz only has dramatically increased the speed where I have signal. Now, the last issue is to get good signal in all the rooms.

If that means I have to add an AP, I'll do it. But I just need expert opinions that I have done everything I can do short of adding an AP.

I prefer to set things up "properly" before throwing more cash at the issue. (Not that an AP will break the bank. I have a spare laying around... actually...) I would just prefer to "do it right the first time."
0
Craig BeckCommented:
I also agree that the device (whether it is a phone or a laptop) must also be able to communicate back. But, if that was the issue, I would expect some devices to work and others to not work
I don't see your reasoning here... Most consumer devices use roughly the same antenna gain and power output, so if anything they would perform more or less the same.

Although 802.11n does offer a slight distance increase you must consider the fact that faster data-rates can't cover an area as large as slower data-rates.  Therefore you might be able to get a 6Mbps signal 200ft away through two or three walls, but only achieve 144Mbps up-to 20ft away in an open space.

It's interesting that this is being experienced over a relatively short distance, but I'd guess the structure of the walls is solid brick, and that there's a couple of them between the client and the AP?
0
DrDamnitAuthor Commented:
The walls are either drywall or plaster, with empty wall spaces. However, given the angle at which the signal would travel (assuming it travels in a straight line) there could be up to 8-12 inches of wall between the APs and the room in question. It is not a 90 degree angle of incidence. It's more like a 15 dgree angle of incidence. And, 1/2 drywall with that angle of incidence could (Conceivably) become 2-3 inches of drywall.

That's the first wall.

The second wall has around a 60 degree angle of incidence. So, that would still be 1/2 - 3/4 inches.

So, we're up to 5 inches per side, and two sides to the wall (empty space in the middle). 10 inches of drywall seems like a stretch. But, for the sake of argument, let's say 8-10 inches of drywall material between the AP and the room.

Even still that seems like a stretch. I would prefer to go with user error on my part because that's fixable.

What do you think?
0
Craig BeckCommented:
Is there any insulation between the drywall?  If so, what type?
0
DrDamnitAuthor Commented:
Normal fiberglass insulation.
0
Craig BeckCommented:
So no silver-backed insulated sheets?

Hmmm I've just looked at your screenshots again.  Ch. 36 looks like it's giving a 'decent' enough signal for a solid link but I'd expect it to be a bit stronger.

This might sound a bit silly, but have you tried orientating the routers at 90-degrees to how they are now?  So what I mean is, if they're sat down, put them on their side and test the signal again, etc..
0
DrDamnitAuthor Commented:
This might sound a bit silly, but have you tried orientating the routers at 90-degrees to how they are now?  So what I mean is, if they're sat down, put them on their side and test the signal again, etc..

I am all for things that sound silly. I'll try this when I get home.
0
DrDamnitAuthor Commented:
After using the settings derived from this conversation, I have significantly increased the throughput from all areas of the house to over 100Mbps on average. The room in the middle of hte house is still down around 40 Mbps on average, but at least there is signal there now.

I will probably add another AP there in the future, but for now, all your insights and help were incredibly valuable.

I tried to split the points up in a thoughtful manner based on the posts that were the most helpful.

Thanks guys.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.