connections keep reappearing in AD Sites and Services

I have a domain with one domain controller at a central location running Server 2008, and several branch locations with DCs running 2008R2.  Each branch is connected to the central location via relatively slow VPN links.

Sites B, C, and D are all connected to site A.  Sites C and D are connected to each other, but Site B is not connected to C or D at all; they don't have VPNs set up and there's no direct connectivity.

In Active Directory Sites and Services, I've set up each site and associated the correct subnets.  In Inter-Site Transports\IP, I deleted DEFAULTIPSITELINK and manually created these site links:
Site A to B
Site A to C
Site A to D
Site C to D.

My problem is that for Site B, under NTDS Settings, connections keep getting automatically generated for replication from sites C and D.  This shouldn't happen, since they can't communicate with each other.  I manually delete the connections, but they come back on their own.

How can I get the KCC to knock it off?
TikTek-ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JaihuntCommented:
So in the Site A to B sitelink you keep only site A and Site B ? If you dont want Site B to contact Site C and Site D you can disable intersite replication and create manual connection between site A and Site B.

repadmin /siteoptions /site:siteB +IS_INTER_SITE_AUTO_TOPOLOGY_DISABLED

reference:

http://terrytlslau.tls1.cc/2011/07/disabling-knowledge-consistency-checker.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike KlineCommented:
Do you have bridge all site links enabled or disabled?  

More on BASL   http://technet.microsoft.com/en-us/library/dd736189(v=ws.10).aspx

Thanks

Mike
0
piattndCommented:
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Life1430Sr EngineerCommented:
You may have some configuration issues in  site links you have configured otherwise KCC would not have created these objects

BTW Is the Site link is showing correct on Site B DC's i.e  is it replicating with other DC
0
SandeshdubeySenior Server EngineerCommented:
As the network isn't fully routed first shutoff Bridge All Site Links (BASL).http://technet.microsoft.com/en-us/library/cc738789(v=WS.10).aspx

I will recommend to create hub and spoke topology as this will suit the requirement ,disable the bridging and create specific IP connectors for each site to connect from the remote site to the hub and add the two sites in each specific connector.Create the site links as below.

SiteA to SiteB
SiteA to SiteC
SiteA to SiteD

If maula connection are created then delete the same and let Kcc do the job.
http://blogs.technet.com/b/markmoro/archive/2012/10/26/3445433.aspx
0
TikTek-ITAuthor Commented:
Disabling this for the site appears to have corrected the problem.  Thank you for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.