Lost permissions to C: drive on Windows 8

So this is irritating. Somehow I lost permissions over the root C: drive on Windows 8. Windows 8 loads, and the Windows Apps all work (such as Windows Store apps; anything except Desktop programs). My account has administrative access to the PC.

I've tried the usual methods of fixing the issue, thus far with no success:

1. I went to the desktop and launched explorer. The C: drive is visible on the list of hard drives. When I double-click it, I get the error message: "C:\ is not accessible. Access is denied." Expected. I right-clicked on the C: drive, selected Properties, and went to the Security tab. It gives me the standard "You must have Read permissions to view the properties of this object. Click Advanced to continue." I clicked on Advanced, and it shows that it's unable to display the current owner. When I click on "Change," I get the error message: "Can't open access control editor. Access is denied." When I click the "Continue" button under "Click continue to attempt the operation with administrative permissions" on the Permissions tab, I get the same error message.

2. I can run cmd within Windows 8, but not as administrator. The command prompt loads normally. When I right-click the Command Prompt shortcut (instead of double-clicking it) and select Run as Administrator, I get the error message: "Windows cannot access C:\windows\system32\cmd.exe." Grr...

3. Next, I opened Settings > Change PC Settings > General. Under "Advanced startup," I selected "Restart now." When the "Choose an Option" screen appears, I select Troubleshoot > Advanced Options > Command Prompt. The administrative command prompt loaded fine, and I attempted to run the commands:

X:\>takeown /F C:\*.* /A /R
ERROR: Access is denied.
X:\>takeown /F C: /A /R
ERROR: Access is denied.
X:\>takeown /F C: /A
SUCCESS: The file (or folder): "C:\" now owned by the administrators group.

Any use of ICACLS fails with Access Denied.

4. At this point, I concede that any effort to fix permissions will not work, which is irritating, because I know these methods work under other Windows versions. Going back to the "Choose an option" screen, I selected Troubleshoot > Refresh Your PC. I accept the warnings and it starts to do its thing, but then it fails almost immediately with the error message: "There was a problem refreshing your PC. No changes were made."  Argh...

Is there any way for me to salvage this at this point? I'm not very familiar with Win8. At the very least, I want to extract the data contained in my documents and pictures folders before doing the restore option to blow everything away, so I'm probably going to have to go with booting Ubuntu or something off a USB drive.
LVL 1
elorcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arrorynCommented:
Might be a basic shot, but if the permissions changes work under a different OS, then why not try creating a ...... and booting to the mini Windows XP mode. This should allow you to interrogate the HDD and specifically the C vol permissions from a different angle, and modify them using the methods you've already tried in W8?
0
JohnBusiness Consultant (Owner)Commented:
I am not sure what you might have done.

1. Go to ghisler.com and get Total Commander. It comes as a trial. This tool works well on hidden and like folders. Install it. Can you see C:\ with Total Commander.

2. Go to Action Center, Recovery link and note the bottom link that says you can Refresh your PC. This leaves data intact and refreshes the operating system. I have used Refresh and it left my 150Gb of data and machines intact.

I would prefer if Total Commander would help you because then you could back up your data first just in case.

.... Thinkpads_User
0
aadihCommented:
Try:

Boot up in safe mode command prompt (if you could).

At the command prompt, type rstrui.exe and restore your computer to an earlier time (before the access problem).

May not work, but if it does, it'd be the quickest and easiest solution.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

arrorynCommented:
Sorry Thinkpads, wasn't aware of the implications. Shan't link it again.
0
elorcAuthor Commented:
I forgot to add to the original text: I tried to do a system restore, but that failed with an access denied error message as well.

I pulled my data off the drive with Ubuntu.

Here's the real pain: After I got the data off the drive, I tried the Troubleshoot > Restore your PC option. No luck. It fails with the same error that the refresh option fails with.

When I log back into Windows 8, if I try to go to Settings > Change PC Settings > General, if I click on "Get started" under "Remove everything and reinstall windows," nothing happens.
0
JohnBusiness Consultant (Owner)Commented:
If Remove everything and reinstall Windows does not work, System Restore and Windows 8 Refresh will not work either.

You have your data - Great!  

Now how did you get to Windows 8 in the first place?  Do you have a DVD that you can use to do a Fresh install of Windows 8?

.... Thinkpads_User
0
elorcAuthor Commented:
Thinkpads: It's a Samsung 700T SmartPC, which came with Windows 8 installed. There wasn't any recovery media that came with the device. I had assumed (apparently incorrectly) that the reinstall option under Settings would take care of it. I'm not sure where else to try to initiate a recovery.
0
JohnBusiness Consultant (Owner)Commented:
With some computers, you can turn off, turn back on and press F11 right away to initiate a recovery from the recovery partition.   Try that.

Also contact Samsung to see if they can ship you recovery DCD's.

.... Thinkpads_User
0
JohnBusiness Consultant (Owner)Commented:
Here from Samsung Support (link below) is the procedure for Recovering your tablet.

http://www.samsung.com/us/support/howtoguide/N0000658/8905/138365/XE700T1C-A04US

There is a warning about altering the existing backup (which you may have done). It talks about a process to boot and then takes you back through the Charms process which you said you did.

Read through this and see if it helps.

... Thinkpads_User
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
elorcAuthor Commented:
Well that was an epic battle. The recovery method that you suggested worked, but not as the article explained.

For anyone else who ran into this issue, you'll need an 8 GB USB drive.

1. Reconfigure UEFI to the following settings. I did this through Windows 8 by rebooting into the advanced startup.
   a. Go to Settings > General, and select the option to boot into Advanced Startup.
   b. At the "Choose an option" screen, select "Troubleshoot."
   c. Select "Advanced options" on the Troubleshoot screen.
   d. Select "UEFI Firmware Settings" on the Advanced Options screen, then select "Restart."
   e. When the Samsung BIOS Configuration screen loads, click "Advanced."
   f. Under the Advanced options, DISABLE "Fast BIOS Mode."
   g. Next, click on the "Boot" option.
   h. Under the Boot options, DISABLE "Secure Boot." When you do this, an option will appear directly beneath it labeled OS Mode Selection. In the OS Mode Selection drop-down menu, select "CSM and UEFI OS."
   i. Click "Save" on the right side of the BIOS screen, then select "Yes." The tablet will reboot.

2. Power off the tablet.

3. Hold down the "Volume Up" button on the left side of the tablet. While holding this, power the tablet back on. It will eventually boot into the recovery console, which could take a while to load.

4. Once the recovery console loads, you can try to do the recovery from here. In my case, most likely due to the permissions issues, this did not work. Instead, I did this:
   a. Connect your 8 GB (or larger) USB drive to the tablet.
   b. Select the "Factory Image" option on the lower left corner.
   c. Export the firmware to the USB drive.

5. Finally, when the export is complete, reboot and boot from the USB drive. This will take you into a very similar-looking recovery console as the one you were just in (sans a few options). Begin the recovery process, which should work now.
0
aadihCommented:
Great.  Not only you solved the problem but also shared with us the exact solution. :-)
0
JohnBusiness Consultant (Owner)Commented:
@elorc - Thank you for a very informative link. I am glad you were able to recover the tablet, and I was happy to help.

.... Thinkpads_User
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.