TCP/IP corrupt

A customer complained that she could not browse the Internet.  When I rean IPCONFIG, I got the error "An internal error occurred:  The request is not supported."  The OS is Windows XP SP3.

I have tried resetting the TCP/IP stack and WINSOCK with netsh,  a repair installation, and reinstalling the TCP/IP protocol.  Nothing has worked.

When I did the repair installation, there was a dialog that asked for McAfee NDIS during the network installation.  McAfee did not appear to be installed.  There is no reference to McAfee in Add and Remove Programs.  Revo was not any better at finding it.

I checked the running processes in Task Manager, and the files for Site Advisor are in fact running even though I have everything turned ff in MSCONFIG.

I tried removing all traces of McAfee with MCPR.exe, but it returns "Incomplete Installation" and stops.

I suspect that Site Advisor and/or another remnant of McAfee is the root of the problem, but how do I get rid of McAfee?
Who is Participating?
Scott ThompsonConnect With a Mentor Computer Technician / OwnerCommented:
Yes, run the McAfee installation to install,  then restart and run MCPR.exe
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Log in as an Admin User and run System File Checker. Run SFC /SCANNOW and allow to complete. Restart the computer and test.

This is XP (dead) so you will need the XP DVD to run System File Checker.

This is where I would start to see if it will fix TCP/IP for you. SFC (probably) won't do anything about McAfee.

One way to try to deal with McAfee is to see if you can install it. If so, you may then be able to uninstall it. I have done that with some software in XP.

.... Thinkpads_User
rhaveyAuthor Commented:

I had already run SFC.  I am running it again.  If a repair installation didn't fix it, I'm not too hopeful that SFC will.

I will see if the customer has the McAfee disk tomorrow.
We Need Your Input!

WatchGuard is currently running a beta program for our new macOS Host Sensor for our Threat Detection and Response service. We're looking for more macOS users to help provide insight and feedback to help us make the product even better. Please sign up for our beta program today!

Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:

If you can uninstall the nic driver and reinstall the driver

i think you'll best backup your data, and do a fresh install.
this one can be running more than 10 years...
Have you tried safe mode with networking on that machine?

Please run "fltmc" command in the command prompt and see if any filter drivers are causing the issue.

The fltmc command is used see if there are any filter drivers on your system. If you find any filter driver remove them.
rhaveyAuthor Commented:
I thought that this had been closed weeks ago.  I must have hit the wrong button.  Thank you.
JohnBusiness Consultant (Owner)Commented:
@rhavey - Thanks and I was happy to help.

... Thinkpads_User
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.