2 Exchange Server / Outlook choosing wrong one

Helo everybody,

we have a new customer, running 2 Exchange Server 2010 with DAG.
Now there are users which are Outlook-connected to Server I or Server II.

I moved all Postboxes to the Database of Server I.
But if i try to reconfigure the Outlook of a User (previously connected to Server II) to connect to Server I, after hitting the button "search" he changes back to Server II.

I did find some hints @ google where the was a hint it had something to do with SP3, but all Servers are Up-2-date and have the latest SPs and Updates/Patches.

So does anyone have any idea what is my failure?

Thanks in advance, Carsten
Who is Participating?
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
Nothing is wrong.
The server the mailbox is on and the server Outlook connects to are completely independant. The fact that you may have both roles on the same server means nothing.
Outlook connects to the Client Access Role, and will use the server defined on the database.

get-mailboxdatabase| select identity, RPCClientAccessServer

While you can change the name of the server listed, as you are using a DAG, you should be using an RPC CAS Array.
In the event of a DAG failover the clients will NOT follow to the other server.
Furthermore, if you do change the value of RPCClientAccessServer whether it is to another CAS role or an RPC CAS Array host, the clients will not use it automatically. You have to repair the Outlook clients.

The Exchange implementation, while not best practises is doing what I would expect.
Remember, mailboxes don't "belong" to a server in a DAG.

itechpartnerAuthor Commented:
Simon, thanks for your help.
Is there any chance to get rid of the DAG, back to a single Exchange-Server?

Never did this before....
Simon Butler (Sembee)ConsultantCommented:
Why would you want to do that? Just because you don't understand how something works shouldn't mean you should change the configuration of the platform and reduce the high availability options that the customer has. That may seem blunt, but that is how I see it.

This problem has NOTHING to do with the DAG. This is how the client access configuration.
It is easily resolved.

itechpartnerAuthor Commented:
Hi Simon, thanks for your open words.

Its not about not understanding something and then try to change a running configuration - it is already solved based on your input. So thanks for the hint into the right direction.

My question was pure interest. May be i should have written my question different, so you did not have the feeling it has some connection to my existing problem.
I never changed a running DAG configuration before.

So again thanks for your help Simon.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.