Setup Cisco Routers Between Two Branch Offices

Hi i would like to setup 2 Cisco 892 Routers for 2 Branch Offices. They will be connected through a Metro E connection.

Cisco 892 has 1GE, 1FE and 8 Managed ports

Branch1 (Cisco 892) --------> Metro E <-------- Branch 2 (Cisco 892)


Branch 1

Vlan 101 Voice       10.10.101.0 /24
Vlan 102 Data        10.10.102.0 /24
Vlan 103 Man        10.10.103.0 /24
Vlan 104 Srvr           10.10.104.0 /24
Vlan 105 Gst           10.10.105.0 /24

Branch 2

Vlan 101 Voice       10.10.111.0 /24
Vlan 102 Data        10.10.112.0 /24
Vlan 103 Man        10.10.113.0 /24
Vlan 104 Srvr         10.10.114.0 /24
Vlan 105 Gst           10.10.115.0 /24

Please assist me with a suitable configuration. i have setup single site routers but have never setup branch to branch type connection through Metro E.

Also i would like to prioritize the VOICE traffic (VLAN 101) .
thank you in advance
icdl101Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

icdl101Author Commented:
Also each devices on the same VLAN even though they have different ip subnetneed to talk to each other ie (Vlan 101 Voice       10.10.101.0 /24 -----  Vlan 101 Voice  10.10.111.0 /24)
So will i have to create routes on each router?
0
LibipappachenCommented:
Hi,


     Configure a point to point L3 link between branches and do the routing as required.

Helpful link.

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/routconf.pdf 

let me know any help need.

BR,
Libi
0
icdl101Author Commented:
Hi Libi,

it seems the GE is a WAN interface according to the above document.

i was configuring the GE as LAN and FE as the WAN, does that make a difference ?

so i should not configure the WAN interfaces as lets say 192.168.111.1(Router1) and 192.168.111.2(Router2)

how would i  configure L3 Point to Point
0
Webinar: Miercom Evaluates Wi-Fi Security

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom how WatchGuard's Wi-Fi security stacks up against the competition in our upcoming webinar!

LibipappachenCommented:
Hi,


You can configure any router interface as a WAN or LAN unless it’s specified on that device.

yes, you can configure the WAN interfaces with 192.168.111.0/24 if the Metro E link is up we will get a ping reply.

let me know any help need.

BR,
Libi
0
icdl101Author Commented:
hi Libi,

i am trying following configuration, please state if i m going in the right direction.


Current configuration : 1611 bytes
!
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
ip source-route
!!
ip cef
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO892-K9 sn FGL160924XZ
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
 !
!
interface FastEthernet0
 description Connection to LAN Switch
 switchport mode trunk  (Should  i classify this as Trunk Port, is this correct?
 !
!
interface FastEthernet1
 !
!
interface FastEthernet2
 !
!
interface FastEthernet3
 !
!
interface FastEthernet4
 !
!
interface FastEthernet5
 !
!
interface FastEthernet6
 !
!
interface FastEthernet7
 !
!
interface FastEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0
 description Wan Connection to Router_2
 ip address 192.168.111.1 255.255.255.252
 duplex auto
 speed auto
 !
!
interface Vlan1
 no ip address
 !
!
interface Vlan101
 ip address 10.10.101.1 255.255.255.0
 vlan-id dot1q 101
  description Voice Vlan
  exit-vlan-config
 !
 !
!
interface Vlan102
 ip address 10.10.102.1 255.255.255.0
 vlan-id dot1q 102
  description Data Vlan
  exit-vlan-config
 !
 !
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler max-task-time 5000
end

Router_1#

---------------------------------------------------------------------------------------------------------






Do i have to specify which vlans are allowed on the Fe 0 and Ge 0 ports. if so which command to run.

thanks
0
icdl101Author Commented:
i cannot seem to be able to create sub interfaces on this router. Is it some sort of limitation on these series of routers ?
0
LibipappachenCommented:
Hi,


      How or where you connecting your PC and IP phones in this config, do you have any managed access switches?

BR,
Libi
0
icdl101Author Commented:
Hi,

Since i cannot do router on a stick config.

i have to create a port on the 892 cisco FE 0-FE7 for each vlan.
I have HP Procurve J9020a managed switches.

 though in the test environment i i m using simple cisco layer 2 switch.

my dilemma is do i create VLAN ip addresses or should i create Port Ip addresses on the
cisco Fe0 - Fe7 and then give those ports unique VLAN Id.

and what routing i will have to configure.

so simply if there is a similar config which i can follow i would be more than happy to emulate that.

thanks
0
LibipappachenCommented:
Hi,

I suggest the connection between your router and switch should be an etherchanal link.

R1&2
!
interface FastEthernet1
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet2
 switchport mode trunk
 channel-group 1 mode on

!
interface Port-channel1
 switchport trunk allowed vlan 101,102
 switchport mode trunk
end

EIGRP will be the good option for the routing.

R1
!
router eigrp 100
 passive-interface default
 no passive-interface GigabitEthernet0
 network 10.10.0.0 0.0.255.255
 network 192.168.111.0 0.0.0.3
no auto-summary
!

R2
!
router eigrp 100
 passive-interface default
 no passive-interface GigabitEthernet0
 network 10.10.0.0 0.0.255.255
 network 192.168.111.0 0.0.0.3
 no auto-summary
!
If you can, please configure the Common network services like Domain Name, Active Directory, DNS, DHCP Server, Authentication Control System, and Network Time Protocol Server etc…

BR,
Libi
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
icdl101Author Commented:
hi Libi,

i have a working and tested configuration thanks to you.
i have attached the working configs incase some else finds it helpful here.
I decided not to go with EtherChannelLink. as i have Cisco on one side and HP on other side, and i don't want to create more headaches just  in case

I created a Trunk Port on Fa 0 and it is working, and used your EIGRP settings.

Now how do i prioritize the VOICE VLan 101 Traffic  ??
ROUTER-1-and-ROUTER-2-Config.rtf
0
icdl101Author Commented:
Libi
i would be more than happy to open another question with regards to prioritize the VOICE VLan 101 Traffic and award you points for this questions.
0
LibipappachenCommented:
Ok good, thanks,

BR,
Libi
0
icdl101Author Commented:
Thank you so much for your assistance
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.