• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 869
  • Last Modified:

People picker address book not up to date for some users, MOSS 2007

We have a Sharepoint Infopath form that has a people picker on it. We are running MOSS 2007. Every now and then we have a user who cannot see his name in the address book. We have tried setting compatibility mode and clearing cache. I think it is something on the local machine because one user had it and then he got a new PC and the issue went away. Those of us on other PCs can see his name. Is something cached and if so, is there a way to clear it on his local machine?
  • 3
1 Solution
Rainer JeschorCommented:
the issue should normally not relate to the client as the LDAP query is executed from the SharePoint Web Frontend server.
A good overview what happens in the back:

From my experience, issues with people picker normally directly relate to issues of your AD / DNS servers. Either there are Domain Controller listed in AD which no longer exists, there are network issues, ...

Therefore the issue is probably on the frontend server - either directly in the connection to AD or that it is related to a cache held for other searches.

Could you perhaps post more details about your MOSS farm? Exact version number (patch level), number of WFEs and app servers, number of domains (if there are trusts / subdomains), ...

Thanks and HTH
davidweekleyhomesAuthor Commented:
It will take me a while to gather that info since we have no real in house Sharepoint admin person.
But the thing that bothers me about your answer is that this person can be selected on the same form at another person's computer, or by that person logged on to another pc. So it sounds like some kind of setting in the browser maybe. We have tried a number of things and will now compare all the settings on a working one with a non working one to isolate the issue.
davidweekleyhomesAuthor Commented:
Update. It really is something in IE, apparently. Someone on our help desk worked with the person and got it to work by resetting IE:
Internet options

Thanks for looking into this anyway. Hope this solution helps someone else.
davidweekleyhomesAuthor Commented:
I am accepting this solution since it is the only one we had that would work.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now