Avatar of Salonge
Salonge asked on

Email address format

Good day all

Here is my dilemma.  I just installed Exchange 2010 and moved my mailboxes without issue.  But I noticed that my email address has gone from FirstnameLastname@domain to FirstnameLastnameinitial@domain.  I realized this when people starting noticing that when getting reply messages they saw the email difference.  I was able to change the reply message within the properties of the mailbox and set the original email to set as reply.  Unfortunately, our configuration is not one on the policy list so I could not create a new policy to change everyone at a time; and it won't let me edit a legacy policy.  But I also noticed that this does not change when I am sending an email; the email address shows up as the firstnamelastnameinitial@domain.  Currently people haven't seem to notice, but I have and they are going to want it fixed.  I don't see anywhere this can be changed.  Can anyone help?
OutlookExchange

Avatar of undefined
Last Comment
Simon Butler (Sembee)

8/22/2022 - Mon
dinips

Below is the solution where it will take you the setting menu u can select in many formats for your domain.

1.      In the Exchange Management Console navigate to Organization Configuration/Hub Transport, and then select the Email Address Policies tab.

2.      In this scenario we’ll just modify the default policy for all mail-enabled objects. Right-click the Default Email Address Policy and select Edit.

3.      Click Next to skip past the introduction and conditions, until you reach the Email Addresses part of the policy. Click on the Add button.

4.      The Email address local part is an optional setting. If you do not specify one the Alias is used as the prefix of the email address. If you do specify one you can use the Alias or other combinations such as Firstname.Lastname.

5.      Next type the domain name or click Browse to choose it from the list of Accepted Domains.

6.      Click OK once you have configured the new SMTP email address. Select the newly added SMTP address and click on Set as Reply.
dmwynne

Everything you need to know is defined here.

http://answers.oreilly.com/topic/1240-how-to-create-and-manage-exchange-server-2010-e-mail-address-policies/

You should be able create a new policy and have it apply to all.
ASKER
Salonge

When I try to do this, I get a message that this only can be done via the Set-EmailAddressPolicy task because this is a legacy policy.  How is this done?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Simon Butler (Sembee)

Have you removed the old Exchange server yet?
It sounds like you haven't completed the migration. The email address policy needs to be upgraded to the new version before you do do anything with it.

Although it is best practise to leave the default policy alone and create additional policies.

Simon.
ASKER
Salonge

I can't remove the old Exchange just yet.

I looked at the email policy on the legacy and it really doesn't help.  So I really want to create a new policy, but the address format that I want to use is not an option on this email format list.  How would I create a new format and not use the alias?
ASKER CERTIFIED SOLUTION
Simon Butler (Sembee)

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question