HTTP 400 error on OWA and outlook for shared mailbox

I have a few problems after I switched from windows integrated OWA login to SSL form based.
One computer is constantly having issue to force OWA users to sign in every 5-10 minutes.
The other computer shows http 400 after login id and password were typed no matter who logins into the computer.

The other question is regarding sharing mailbox.
I usually share mailbox  and go to outlook/tool/email accounts, then add it as additional mailbox. this worked well if the inbox has only several subfolders. But now I have one user who has '150' subfolders under inbox. As far as I know, each subfolder has to be configured for sharing and permission to give. Is there any other way simple. Just share the root mailbox and when I hook it upto the other user's outlook, it shows all subfolders of the mailbox?
LVL 1
crcsupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

crcsupportAuthor Commented:
I resolved the 2nd problem I described above, sharing mailbox. I was able to give full mailbox permission under AD which modified permissions on all subfolders automatically instead of going through in Outlook.

I am still doing research on the first issue 'HTTP 400'. It seems like certificate issue because the computer's IE keeps popping up certificate warning when I browse internet. I cleaned up history, cookie, temporary files, reset security in IE options, still the same problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Paul SDesktop Support Manager / Network AdministratorCommented:
can you post a screenshot of the 400 error and the exact behavior needed to reproduce it?
0
crcsupportAuthor Commented:
I'm sorry being late. Here it is.

err
0
crcsupportAuthor Commented:
I think I found the problem. The language setting of mailbox and internet explorer is not being matched. I had to either change language setting in internet explorer or in user's exchange mailbox.

To change through IE;
right click, then Encoding, make sure 'Auto-Select' is checked and UTF is selected.

To change  mailbox default language setting for OWA user;

http://enterpriseit.co/microsoft-exchange/http400-bad-request-error-attempting-to-change-password-via-owa/
0
crcsupportAuthor Commented:
as I found
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.