Exch 2007 Outlook Anywhere fails to connect

We have a client with Exch 2007 where we have installed the UCC (we have done this for many clients, OA/autodiscover works) and we cannot get outlook anywhere to connect via autodiscover or manually configured. External DNS is correct with A autodiscover.client.com. We believe the problem is that their www record is at their vendor's webserver and testexchangeconnectivity FINDS an autodiscover xml at that site. That then fails on a Cert name mis-match.
On the second step (autodiscover.client.com), testexchcon DOES find our valid 2007 cert and all passes.
We do not think OL gets past the first cert name mismatch to our good cert.
We even tried removing the DNS A record autodiscover.client.com and adding the srv record, but thats checked last and we think autodiscover stops on first step. Any way to bypass the first check on domain.com or other ideas?
Thanks!
garf133Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SteveCommented:
yipes. so the website has an autodiscover location and xml file? Assuming the root domain record points to the website this is a big problem.

As long as the root domain responds to autodiscover requests you're not going to find a way around it. That comes above the other options in the list of autodiscover attempts so you'll have no choice but to look into it.

does the website serve https? does it have an autodiscover folder?
0
garf133Author Commented:
Yes, thats the problem, the vendor that hosts our client's website does have THEIR ssl and ExRCA sees that first and my clients Exch ssl second pass. We have contacted the vendor to see if they can do a "workaround", not sure that that would be?
The website https://client.autodiscover.com returns a 404 with file paths. We have no access to the site itself except through the vendor that hosts it.
0
SteveCommented:
Probably worth confirming to make sure, but it sounds like you may be a bit stuck.

edit the hosts file on a client PC to override the public DNS, as shown below. Try the autodiscover again and see if it works. (remember to put the hosts file back as it was when you're done...)


# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#	127.0.0.1       localhost
#	::1             localhost
	127.0.0.1       yourdomain.com
	89.9.9.9       autodiscover.yourdomain.com

Open in new window


Add the root of your domain to override the public address pointing to your website.
replace 89.9.9.9 with the external IP of your own mail server.

If you try this and it works then you have confirmed that the public website is the cause of the problem.
If it still doesn't work you can now do further testing on this PC knowing the public website isn't the cause of failures.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

garf133Author Commented:
Totallytonto: From their vendor: Public DNS chang, do you think this will work?

"The solution I can think of is they keep “www.domain.com” (A Record) pointing to the VIP “<vendor website ip>”.
 
They redirect “domain.com” (Parent A Record) to their own web server.
Then their webserver can refuse SSL port 8080 and redirect HTTP 80 traffic to “www.domain.com”.
 
This should get Outlook Anywhere to move to the next step."
0
SteveCommented:
seems a bit of a faff, but it's worth a try.

Did you test it using the hosts file?
0
garf133Author Commented:
Yes, and it still fails. We are thinking we will leave the autodiscover.domain.com A record and change the partent domain.com to their Exch outside ip.

We also think the paragraph should have been 443 not 8080 and web server should read Exch server?
0
SteveCommented:
if it fails with the hosts file amendments it suggests the website isn't the problem.


We also think the paragraph should have been 443 not 8080 and web server should read Exch server?

Agreed.
0
garf133Author Commented:
Solved:  We hired Third Tier and together we solved the Outlook Anywhere by removing the Network Solutions DNS @ (name) record that was pointing to the vendors IP.
We solved the internal users getting an Outlook .local cert error by these PS commands:
We fixed the internal cert issue by setting the virtual directories to the following

Set-ClientAccessServer -Identity CAS1-AutodiscoverServiceInternalUri https://webmail.mycompany.com/autodiscover/autodiscover.xml

Set-WebServicesVirtualDirectory -Identity “CAS1\EWS (Default Web Site)” -InternalUrl https://webmail.mycompany.com/ews/exchange.asmx 

Set-WebServicesVirtualDirectory -Identity “CAS1\EWS (Default Web Site)” -InternalNLBBypassUrl https://webmail.mycompany.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity “CAS1\oab (Default Web Site)” -InternalUrl https://webmail.mycompany.com/oab

Set-UMVirtualDirectory -Identity “CAS1\unifiedmessaging (Default Web Site)” -InternalUrl https://webmail.mycompany.com/unifiedmessaging/service.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
garf133Author Commented:
Working with Third Tier was the answer, should have brought them in sooner.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.