Terminal Server sessions not holding default printer

Environment:
  Windows 2008 R2 Server running Terminal Server
  Windows 7 Pro workstations
  Connecting thru RDP
  15 Users with HP Laser printers attached to their local workstations
  I have shared out the local printers and they can print locally but management is getting      tired of having to reset the default printer in the terminal session each morning.
Help!
Thanks
kevin1000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AdrienneSperberTech Support CoordinatorCommented:
If XPS Document Writer exists in the printers, it will continue to default back to that at every login/restart.  The only way to stop it is to remove that printer.
0
djcanterCommented:
There is a bug in 2008 where redirected printer ports aren't removed upon logout and eventually it overflows or assigns bad ports to redirected printers.

Hotfix 2655998 fixes this and there is a FixIt script on the KB article for clearing out those filled registry keys.
0
Ratnesh MishraCommented:
You have a terminal server and you have default printer configured on it. You are using it as printer for all users doing RDP to terminal server.
You mentioned that you have connected local printer to all user and its working fine .
Again default printer on Terminal server is reset every morning to keep the setting working .

I am unable to understand the issue correctly .

Please explain what you want to achieve ? What are the issues you are facing ? If you are using any work-around ,then do let us know ?

Above mentioned hotfix KB2655998 is for deleting inactive port which reside in the registry if the session is not logged off properly. So it fix the issue of Inactive port which ultimately fixes the issue of slow performance.

As you mentioned ,you have local printer connected to the workstation and its working fine so you can use a group policy for printer redirection so that client default printer will be used as default printer in the RDP session .

http://technet.microsoft.com/en-us/library/cc731963(v=ws.10).aspx
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

kevin1000Author Commented:
Ok...thanks for all the input.

I will not be able to work on it until Monday so I will reply then.

Thanks
Kevin
0
kevin1000Author Commented:
Explanation and update:

1)  AdrienneSperber:  XPS Document Writer removed

2)  Rusty & DJ:  More detailed explanation.  

The workstations have their own printer (ie. HP4200) connected to them via USB.

The user logs on to the TS and then wants to print back to their own printer in all programs that they use during the day.

Every morning each user, after logging in to the TS, has to go in to the Devices & Printers and set their own Default Printer.  Even when they logout of the TS for lunch and come back and login to TS again they have to reset the Default Printer.

If the answer to this is too detailed (ie. reg edits etc), is it possible to run a command at login for each different user to make the correct local printer a default?

My boss is driving my crazy over getting this fixed.

Thanks
Kevin
0
kevin1000Author Commented:
Any thought?

Thanks
0
Ratnesh MishraCommented:
Have you Disabled "Do not set default client printer to be  default client printer in a session" in the group policy in the Group Policy Management Console is Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Printer Redirection.
0
kevin1000Author Commented:
Rusty,

Is that what I want?  To have the local default printer be their default printer in the terminal session?

Thanks
Kevin
0
Ratnesh MishraCommented:
Yes , based on the information you have provided it seems so. Let me rephrase the entire situation what i understood :-
Users have a USB printer [HP4200] attached to their local workstation and they are working in RDP session .
The user logs on to the TS and then wants to print back to their own printer in all programs that they use during the day.

So the printer attached locally is the default printer which they want to use on his daily printing activity.

Every morning each user, after logging in to the TS, has to go in to the Devices & Printers and set their own Default Printer.  Even when they logout of the TS for lunch and come back and login to TS again they have to reset the Default Printer.

If you are not using any Group policy it means any configuration your user does after getting into RDP session , have to perform again if he logged out . As the configuration will not remain persistent.
It could be achieved through GPO.
If the answer to this is too detailed (ie. reg edits etc), is it possible to run a command at login for each different user to make the correct local printer a default?

Group policy is the best and easy method .
0
kevin1000Author Commented:
Rusty,

I currently have:

Do not set default client printer to be default printer in a session  ------ Not Configured

Do not allow client printer redirection  ------  Disabled


I'm thinking the second one might be causing the problem.

Kevin
0
Ratnesh MishraCommented:
Request users to make their attached printer as default printer locally.
On RDS/TS server :-
1. Let "Do not allow client printer redirection"  as disabled ,if you enable it then users will not be able to see the local usb printer in the RDP session.

2. Disable "Do not set default client printer to be default printer in a session" .
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.