RDP trhough RWW Gateway does not work. All else does.

Been banging my head for weeks. It's to ask for help.

I have an SBS 2011 server. It has been running RWW with TSGateway just fine for more than a year, them in mid march of 2013 we lost the ability to RDP to computers on the LAN through RWW.

Let me list what does work:
RWW
Check E-Mail
Shared Folders
Computers -> Connect: Server (the sbs server)
RDP from any LAN pc to any LAN pc using name or IP
RDP from the SBS console to any LAN pc using name or IP

What does not work:
Internet pc -> RWW -> Computers Connect
Internet pc using mstsc and setting the RD gateway in the advanced page


Based on the above, noting the mstsc test, I think it has to be the ts gateway itself.  Since I can RDP to the SBS server from outside, and I can RDP to any LAN computer from the SBS server, the "handshake" between the WAN and LAN side of the server seems to be the only point of failure.


Please ask any questions. I'm able to try anything. I did run the "connect to the internet" wizard too.

J.
jasgotAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WORKS2011Austin Tech CompanyCommented:
had a simular issue and fix my network found the problem and resolved it, was an issue with the cert.
0
jasgotAuthor Commented:
I'll check when I am on site Friday. Thanks.
0
jasgotAuthor Commented:
Haven't been there yet. Will report back next week when I am on site.
0
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

jasgotAuthor Commented:
Fix my network did not work.

I have learned more and ask your continued advise.

If I go to IIS Manager to look at Domain->Sites>Default Web site>RDWeb->Pages.... RDWeb does not exist.

I then followed a TechNet article that referred to C:\Windows\Web\RDWeb\Pages\en-us and guess what I found? It doesn't exist.  I then searched for web.config and it doesn't exist either.  I think my TSGateway installation has gone AWOL.

How can I reinstall it?

SBS 2011

Thanks,
Jason
0
WORKS2011Austin Tech CompanyCommented:
it's hidden on SBS2011. To unhide do the following command: dism /online /Enable-Feature:Gateway-UI

Click here for the MS article.
0
jasgotAuthor Commented:
Works2011,
I already have the GUI installed. It's not hidden, it's not yet installed by default.  I was looking for a way to uninstall TSGateway. It's done through ROLES, I'm in the process now.
0
WORKS2011Austin Tech CompanyCommented:
Have you read this MS article?
0
jasgotAuthor Commented:
Yes, that is what I am already doing.
0
jasgotAuthor Commented:
Well, after 6 months I have figured it out.

Suddenly, MS SBS 2011 stopped allowing RDP through the TSGateway to domain PCs with a numeric computer name.

Let me say that this worked flawlessly for 18 months before it stopped working.

The computer names at this location are the same as the telephone extensions. ie; 10,11,12,13,14,15 and so on......

Let me say again.... this has worked flawlessly for 18 months, then sometime in early summer, users could no longer RDP to their desktops from RWW.

I changed the computer names from 10 to Ten, 11 to Eleven, 12 to Twelve, and so on.... It is all working again.

I've been struggling with this for months!!!!! SOLVED.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WORKS2011Austin Tech CompanyCommented:
Do you have Voip? Sounds like DNS is not setup correctly. Either way, glad it's working.
0
jasgotAuthor Commented:
I found the cause by chance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.