what am I missing from this page??

I got this template
http://demo.truethemes.net/Karma-Site-Template/

(if you click on "pages" and choose "homepage-jquery2"..that's the page I want to have)

I created an ASP.Net website app. Copied the files I got from that template. Put the page in Default.aspx. It looks fine on my laptop when I run it.

 Uploaded it to our hosting server. I double checked all the files and I moved the entire thing but this is how it looks like

http://stagingbd.com

what am i missing??
LVL 8
CamilliaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RobOwner (Aidellio)Commented:
it's saying to me that your DNS is setup correctly and is pointed at your host www.hostmonster.com but your files aren't in the right place

https://my.hostmonster.com/cgi/help/upload-site

Can you confirm they're in public_html/ ?
0
RobOwner (Aidellio)Commented:
Also it doesn't look like your host supports ASP.NET.  Can you confirm that they do?
0
CamilliaAuthor Commented:
It does support ASP.Net because I have another site there that works.


Not sure what you mean by your post 39469184. Do you see the site? does it come up for you??
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

RobOwner (Aidellio)Commented:
No... all I see is a site saying welcome to hostmonster:

landing page
0
Dave BaldwinFixer of ProblemsCommented:
"stagingbd.com" reports as IIS 7.5 so it's the right web server.  Either your files are not in the right place or something isn't turned on in your hosting.
0
CamilliaAuthor Commented:
That's weird. I do see the website from my machine.

Try http://stagingbd.com/default.aspx

The files are in the right folder. The site comes up for me but looks like a style sheet is missing but all the CSS files are there. Try the URL above and see if it comes up for you.
This is weird.
0
CamilliaAuthor Commented:
My hosting server says there's a DNS issue on that site. Let me dig into that. I wonder if that's the cause.
0
RobOwner (Aidellio)Commented:
I can see your site when from that last link: http://stagingbd.com/default.aspx

screenshot
0
RobOwner (Aidellio)Commented:
I suspect it's your server is not looking for default.aspx as one of the default index files.  If you upload a simple index.html do you see that when you view just your site: http://stagingbd.com/
0
RobOwner (Aidellio)Commented:
And here's how you do it :)  Shows how to modify your .htaccess file to setup your directory index file.

https://my.hostmonster.com/cgi/help/184
0
CamilliaAuthor Commented:
thanks. I'll change it on hostmonster. Now, you see that site in your post 39469878, what am I missing that the site looks like that? all the CSS files are there. I double checked the image folder too.

Do I need to make the change to hostmonster first?
0
CamilliaAuthor Commented:
I fixed the DNS that our hosting server reported in Hostmonster. The site still looks like it has missing CSS styles. Not sure how to go about debugging this. I have all the files here.

I cleared the cache too.

I also have another site that works fine...on the same server..for 2 yrs now.
0
guru_samiCommented:
I think you have anonymous access denied to your website in web.config. So your css and javascript files aren't loaded.
Explicitly allow access to all users to your css and js files.
0
CamilliaAuthor Commented:
I removed all these sections, cleared the cache and still didnt look right.

I put them back and still the same. Now, if you go to the url above, it adds "returnURL" at the end.

These are the sections I took out and added back in to debug. I dont have the "Admin" and "Provider" folders yet but I added them in webconfir for later. I don't know if that would make a difference.

I'm thinking about deleting the entire folder and uploading just a simple page and see how that would look like.

 
 <authorization>
      <deny users="?"/>
    </authorization>


	<location path="SessionExpired.aspx">
		<system.web>
			<authorization>
				<allow  roles="Admin"/>
				<deny users="*"/>
			</authorization>
		</system.web>
	</location>

	<location path="Account">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	<location path="css">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	
	<location path="images">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	<location path="js">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	<location path="Scripts">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>

	<location path="Default.aspx">
		<system.web>
			<authorization>

				<allow users="*"/>
			</authorization>
		</system.web>
	</location>

	<location path="swf">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	
	<location path="Agreement">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>
	<location path="Admin">
		<system.web>
			<authorization>
				<allow roles="Admin"/>
				<deny users="*"/>
			</authorization>
		</system.web>
	</location>
	<location path="Provider">
		<system.web>
			<authorization>
				<allow roles="Admin,Provider"/>
				<deny users="*"/>
			</authorization>
		</system.web>
	</location>

Open in new window

0
guru_samiCommented:
For testing purpose...can you allow access to everyone:
<authorization>
      <allow users="*"/>
</authorization>

Open in new window

0
CamilliaAuthor Commented:
Changed it. Cleared cache just in case. Brought up the site and the URL looks like this and no CSS applied to it.

http://www.stagingbd.com/Default.aspx?ReturnUrl=%2f


I've attached the webconfig. Running out of ideas. The only thing i can think of is to delete it and upload another site. But it's not like this is a huge site. It's just the default.aspx.

Maybe put the default.aspx in the same folder as the CSS and see if that would work and narrow down the issue. Not sure
webconfig.txt
0
CamilliaAuthor Commented:
And, look at these 2 screenshots.

I have another site on the same server that works. The CSS folder for the one that doesnt work...the files...look "green". The other one that works...the files look like regular files.

Does it mean the CSS file wasn't included in the project?? (running out of ideas and I know this might seem absurd :))
Nowork.png
works.png
0
CamilliaAuthor Commented:
I copied default.aspx to the CSS folder and then tried this but still no!

http://stagingbd.com/css/default.aspx
0
CamilliaAuthor Commented:
One more observation:

On my laptop, locally, if I do "inspect" in Chrome, I can get the CSS's line number when I hover over an element.

In the uploaded one, it doenst give me the CSS's line number or the CSS file's name.

Correction I changed the webconfig to this. Cleared cache but still the smae result

<authorization>
      <allow users="*"/>
    </authorization>
0
guru_samiCommented:
I see your web.config has  <deny users="*"/>
Can you make it to  <allow users="*"/>
0
RobOwner (Aidellio)Commented:
Under view source, I click on the css/mystyle.css and it just redirects me to the Default.aspx page again.  I would suspect it's permissions that guru_sami is eluding to
0
CamilliaAuthor Commented:
1. I had made a mistake in the webconfig. I changed it to allow users = "*". It's attached. But still no change. I cleared the cache too.

2. I have another site on the same server. I stopped that just to make sure there's no confict but still the same.


3. I also uploaded the HTML file that came with my template index-jquery-2.html to the root folder. I clicked on it and doesnt look correct. I also added this to webconfig and tried
stagingbd.com/index-jquery-2.html but it redirected me to default.aspx with this URL.

http://stagingbd.com/Default.aspx?ReturnUrl=%2findex-jquery-2.html

<location path="index-jquery-2.html">
		<system.web>
			<authorization>
				<allow users="*"/>
			</authorization>
		</system.web>
	</location>

Open in new window


4. Maybe I should delete the entire site and try just a default.aspx with a simple CSS to see if that works.
webconfig.txt
0
RobOwner (Aidellio)Commented:
What did you end up changing if anything in your .htaccess file?  Can you post what the contents currently are?

http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/CSS/Q_28232275.html#a39469889
0
CamilliaAuthor Commented:
I didnt change anything in .htaccess file. It's a PHP file and I didnt see a place to add default.aspx. I will post the content of that file soon.
0
CamilliaAuthor Commented:
This is what I have in the .htaccess file

# Use PHP5 Single php.ini as default
AddHandler application/x-httpd-php5s .php

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Open in new window

0
RobOwner (Aidellio)Commented:
So you haven't followed the directions given here: https://my.hostmonster.com/cgi/help/184 to set the index to Default.aspx?
0
CamilliaAuthor Commented:
see my above post. I don't know where to change it. Also, I didnt do this for my other site. I have that site with godaddy, tho.
0
RobOwner (Aidellio)Commented:
Hey I've just seen your post above about the files being green. that means they're encrypted so you'll need to decrypt them before uploading.

http://windows.microsoft.com/en-au/windows-vista/encrypt-or-decrypt-a-folder-or-file

To decrypt a folder or file

Right-click the folder or file you want to decrypt, and then click Properties.

Click the General tab, and then click Advanced.

Clear the Encrypt contents to secure data check box, and then click OK.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CamilliaAuthor Commented:
let me try
0
RobOwner (Aidellio)Commented:
It also seems you need to be logged in to view the site. If I try and access any of your css or scripts it is redirecting me to your Default.aspx file with a ReturnURL parameter, which is a common thing to do with authentication to return the user to the page they've requested after logging in.  Is that your intended purpose?

such as:
http://stagingbd.com/Default.aspx?ReturnUrl=%2fjs%2fkarma.js

This is in your webconfig:
<authentication mode="Forms">
			<forms loginUrl="Default.aspx" defaultUrl="~/Admin/Default.aspx" timeout="2880"/>
		</authentication>

Open in new window

0
RobOwner (Aidellio)Commented:
You should be aware that none of your scripts are loading either so either it's the encryption issue as well or something else?  Are those files "green" too?

If you comment out the authentication does your site work?
<!--
<authentication mode="Forms">
			<forms loginUrl="Default.aspx" defaultUrl="~/Admin/Default.aspx" timeout="2880"/>
		</authentication>-->

Open in new window

0
CamilliaAuthor Commented:
I'm uploading the un-green files now. I'll see how that works. Then I'll take a look at 39472265
you just posted. I hope this is it.
0
CamilliaAuthor Commented:
Yes, that was it! It was the encrypted files! So, it wasn't "absurd" as I thought :)

Thank you so much for sticking with this. I still have more issue with it but I will open a new ticket for it.

Thanks again.
0
RobOwner (Aidellio)Commented:
no certainly wasn't absurd and talk about left field! :)
0
CamilliaAuthor Commented:
I know! You're the best. Thanks again
Kamila.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
CSS

From novice to tech pro — start learning today.