Exchange 2013 OWA Http to Https redirect not working.

hello I am having a lot of issues trying to get the https redirect working on my 2013 Cas servers both are running windows 2012 and exchange 2013 cu2
if I enter webmail.domain.com it goes to http://webmail.domain.com,  if I enter https://webmail.domain.com it will redirect to https://webmail.domain.com/owa

what I want is to enter webmail.domain.com and have it redirect to https://webmail.domain.com.

what I have done so far is the following:
 I have entered the redirect on the default website using the 302 page and removed the required ssl from the ssl settings.  I have also verified all the following directories are set :

 
aspnet_client :Enable SSL,Uncheck redirect

 
Autodiscover Enable SSLUncheck redirect

 
ecp Enable SSL Uncheck redirect

 
EWS Enable SSL Uncheck redirect

 
Microsoft-Server-ActiveSync  enable SSL Uncheck redirect

 
OAB Enable SSL Uncheck redirect

 
PowerShell DISABLE SSL Uncheck redirect

 
Rpc Enable SSL Uncheck redirect

this did not work for me,  if I just enter webmail.domain.com still get 403 page on one cas server and 500 error on second


2.   I went into the error pages on the default website and set the 403 error page to redirect to 302 page with the url https://webmail.domain.com/owa


this did not this did not work for me,  if I just enter webmail.domain.com still get 403 page on one cas server and 500 error on second


3. I made a default.htm page and put in the inetpu\wwwroot forlder with the following.
<meta HTTP-EQUIV="REFRESH" content="0; url=https://webmail.domain.com/owa">

and this did not this did not work for me,  if I just enter webmail.domain.com still get 403 page on one cas server and 500 error on second


any help would be great.  on what to do or even how to reset it and start over.
all 3 of these are still in place.

is there a different default.htm code to use ? should I just remove it completely, or remove the redirect on the 403 page ?

I just really need it to redirect from webmail.domain.com to https://webmail.domain.com/owa.       this is how it is currently working on 2007.

if I enter https://webmail.domain.com  it will redirect to https://webmail.domain.com/owa on both cas servers.
mndthegap1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SeanSystem EngineerCommented:
I have my exchange 2013 setup to redirect and i have never needed to create a html page with a meta redirect. Here are my settings.

default webpage - redirect enabled, 302 found, require ssl disabled, ignore client certs
aspnet_client - redirect enabled, 302 found, ssl disabled, ignore client certs
autodiscover - redirect disabled, ssl disabled, ignore client certs
ECP - redirect disabled, ssl disabled, ignore client certs
EWS - redirect disabled, ssl disabled, ignore client certs
Active Sync - redirect disabled, ssl enabled, ignore client certs
OAB - redirect disabled, ssl enabled, ignore client certs
OWA - redirect disabled, ssl disabled, ignore client certs
powershell - redirect disabled, ssl disabled, ignore client certs
RPC - redirect disabled, ssl disabled, ignore client certs

Hope this helps.
0
mndthegap1Author Commented:
should I delete the default.htm or rename it ?
and should I remove the redirect I have on the actual 403 error page ?
0
mndthegap1Author Commented:
okay so I configured all the settings as you have listed above.
I removed the redirect on the 403 error page and removed the default.htm

now when I enter webmail.domain.com it will redirect to http://webmail.domain.com/owa

but does not add the https:    so its getting there.
also when I log in I get a error page that something went wrong with the following in the url

http://webmail.company.com/owa/auth/errorfe.aspx?httpCode=500&msg=4056147497

should I enable SSl on owa directory ?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

SeanSystem EngineerCommented:
The only changes you should have needed to be make would be through IIS. I would undo anything you did by manually editing the default.htm page or anything like that.
0
SeanSystem EngineerCommented:
on your redirect do you have https://webmail.domain.com/owa? you shouldn't have ssl on the owa directory.
0
mndthegap1Author Commented:
sorry the ? was a typo
0
SeanSystem EngineerCommented:
sorry, it was a question was not intended to be part of the domain link. The thing to make sure you have is the https as part of your redirect.
0
mndthegap1Author Commented:
ill double check.  one one cas server it seems to work but after login
i get the above error but if i refresh 1 or 2x it comes goes through.

on the second cas server it still just redirects to the http://url  but if i put https again it will redirect and again i need to refresh a few times after log in.

ill double check the settings again.

thanks for the help so far.
0
mndthegap1Author Commented:
for some strange reason the only way I got this to work was to unselect the use 302 and select redirect all requests to the exact url.

I am still able to get to the /ecp and other directories aswell.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mndthegap1Author Commented:
all other attempts to resolve the issue did not work.  
the only way to have it work properly was the stated method.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.