Archive policy not working for mailbox Sent Items

I have a mailbox I am trying to set the Sent Items folder to use an Archive policy.  I am able to set the folder policy to 1 year, but then the check mark next to "Use Folder Policy" 1-year disappears after sometime in Outlook.  I have also run the Start-ManagedFolderAssistant on the Exchange server after setting up the folder policy.  But no luck.  The Sent Items folder is not being created under the Archive mailbox.

I was able to use the Folder Policy from my Outlook.  So I'm not sure if there would be any permissions or if the non working mailbox needs repair.  Any help is appreciated.  Thanks.

I am running Exchange 2010 SP3, client machine is Win 7 Pro, Outlook 2010 Pro Plus.
lbideauxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam FarageSr. Enterprise ArchitectCommented:
Does this happen on all machines, or just some?

If it is isolated, then I would run New-MailboxRepairRequest against the mailbox or move the mailbox to a different store (which also resolves corruption).
0
lbideauxAuthor Commented:
I was able to solve the issue using the following command.

New-MailboxRepairRequest -Mailbox "mailbox name" -CorruptionType ProvisionedFolder,SearchFolder,AggregateCounts,Folderview -Archive

It seems the archive mailbox was what needed to be repaired, so the -Archive at the end was needed.

How do I give partial credit to answer?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lbideauxAuthor Commented:
The -Archive was needed to repair the archive mailbox as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.