Internal lan clients cannot access internet after changing gateway to att router

I have a windows 2003 R2 server and is my domain controller running dns, dhcp, around 20 clients running windows 7 professional, another windows 2003 R2 server running apps and a netopia 3347 router.  I have been having issues and I believe I have finally got the router set up as my gateway out to the internet.  My domain controller has two nic cards, one nic conected directly to the router, the other nic to the switch connected to the internal network.  My gateway should be 10.0.0.254 which is the LAN address on the netopia router.  

The domain controller connects to the internet with no issues.  I cannot log into the network on the workstations.  I logged in locally to get the ipconfig.  I am getting a 10.0... ip address on the workstation, the correct dns server, but the wrong gateway.  I had the gateway as my domain controller and that ip address is still showing up on my workstations.  I tried to manually configure a workstation with the correct gateway but that did not work.

So, do I need to do something else now that I changed the gateway on the network?  To the router?  To the server?  I have the server nic gateway pointing to the netopia router.  It seems that the internal clients cannot access the new gateway.

ip address of both nics:

public nic

10.0.0.216  ip address
255.255.255.0 subnet mask
20.0.0.254   gateway

dns - att dns server

private nic

10.0.0.10
255.255.255.0
20.0.0.254

dns - 10.0.0.216

other workstations ip

10.0.0.33
255.255.255.0
20.0.0.216  - pointing to the dns,dhcp server

Do I need to configure something else on my domain controller?  I do have routing and remove access set up - does this need to be changed because the gateway changed?  Do I need anything else on the netopia router?
manch03Asked:
Who is Participating?
 
SouljaCommented:
-Why do you have this server sitting in between the workstations and router. That is problem number one. Is it server firewall purposes or routing something? If routing the nics would be on separate subnets, not the same.
- Why are both server nics on the same subnet. That said, you can't state that one is private and one is public.

- Change the server from being inline to just using one of the nics. Then point your clients to the netopia as the default gateway.
0
 
lruiz52Commented:
Your ip and gateway are on separate networks  on both nics

Nic 1
Ip 10.0.0.216  Sm 255.255.255.0
Range is 10.0.0.1 - 10.0.0.254

20.0.0.254   255.255.255.0
Range 2.0.0.1 - 255.255.255.0

Your gw should be 10.0.0.254 on private nic

And your public ip should be 20.0.0.216
0
 
manch03Author Commented:
Typo
 That should be 10.0.0.216
And gw is 10.0.0.254
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Neil RussellTechnical Development LeadCommented:
Having dual NICs in a DC is asking for trouble.  You dont need it so dont do it.
0
 
manch03Author Commented:
The server routes traffic on the lan. The server is plugged into the same switch as all the networks.  I have always had two nics. This has been working for 5 years. We had to reset the router and lost the settings. I was trying to recreate the set up but am missing something. If I disable one nic which one would that be?  And how would that be configured?  

I also vpn into the network and thought I needed two nics.
0
 
manch03Author Commented:
I did try routing a workstation directly to the netopia router, but did not work. The windows machine would not accept the configuration and tried to troubleshoot. Also, I inherited this so I am not sure why there were two nics. I was told the internal nic routes internal traffic and the external (public) routes the workstations out to the internet.  

If there is a way to make this work with only one nic, please direct me how this would be set up.
0
 
manch03Author Commented:
Correction on above.   The server is plugged into the same switch as all the networks (should be workstations)
0
 
manch03Author Commented:
To add to the issue, while I was on vacation, the compamy called an outside firm in to resolve a connectivity issue. They removed my routing and remote access configuration. I am not sure that is correct either so that could be partnof the problem. I did take screen shots of the nic configurations and they were both on the sam pe subnet before and it worked. I just need to get this working. I really don't care if I have one or two nics. If you suggest that one nic works with fewer issues, please post that solution and I will try it. Thank you
0
 
SouljaCommented:
I don't see how that server was routing traffic between the two networks. One nic would have to be on the inside network and the other on the other network. Your two nics are in the same subnet, so local routing on the server would just choose one nic as it route out of the box.

Can you post your route print from the server?
0
 
manch03Author Commented:
It is the same network. There are not two networks. The public nic is plugged directly into the att router.  There is a crossover cable plugged into another port on the att router into the switch that contains the remaining connections. The private nic is plugged directly into the switch. I would be happy to change this but I do not know which nic to disable or how to configure it so that everything gets routed internally and out to the internet.

How do I get. Route print from the server?  I can post that.
0
 
manch03Author Commented:
Right now the only connectivity to the internet I have is the dc which the public nic is plugged directly into the att router. The clients are not getting routed out through the dc like they did before.
0
 
SouljaCommented:
Go to your command prompt on the server and type route print

Also post your ipconfig /all

If you are only using one network than the serve is not routing. The purpose of routing is to allow two or more networks to talk to on another. That is probably why the outside vendor removed the feature from the server. It wasn't being used.

Post an ipconfig /all from one of your workstations also.
0
 
manch03Author Commented:
After digging through some old documentation and finding out the reason for two nics was for redundancy I did some research on making two nics work on the dc.  I ended up changing the subnet on the public nic but my clients were still pointing to the wrong router.  I looked at my routing and remote access and added some static routes and that seemed to fix the problem with the clients getting the wrong router address.  I did  an ipconfig release and renew on the client and got an error that I googled (something about the loopback) (I did not write down the exact error), but I found that my dhcp server had the wrong router.  Changed that and that fixed the problem.
0
 
SouljaCommented:
Great to hear.

I still don't see where routing and remote access has anything to do with the clients getting to the netopia.

Good luck!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.