Avatar of jeffreychorba
jeffreychorbaFlag for United States of America asked on

Can't get Mac to pull IP using dhcp both wired and wireless static works

I have a MAC that I can't get to pull and IP from my router using DHCP. I try both wired and wireless and it does not.  If I set the settings manually it works. I have also tried different routers and hotspots and it does not matter.
Any ideas,

Jeff
Apple NetworkingApple OSNetworking Hardware-Other

Avatar of undefined
Last Comment
jeffreychorba

8/22/2022 - Mon
arroryn

Do you get any IP address at all, eg a 169.... APIPA address, or just nothing at all?
ASKER
jeffreychorba

yes, I get a 169.x.x.x
arroryn

Generally, with it working on other routers etc I'd say it's an authentication issue, but you've already ruled that out by connecting via ethernet.

What's the router model and firmware version? I've heard, for example, of iPhones on certain iOS versions that can't authenticate to the Netgear APs that have the firmware version 5.0.x - might be a known bug?

You've tested the device on other routers; have you tested other devices on this router?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Craig Beck

I 'think' this is because you have a DHCP Client ID configured on the MAC.

Try removing it and see if that helps.

This might be of use...

https://discussions.apple.com/thread/2720975?start=0&tstart=0
ASKER
jeffreychorba

I get an IP of 169.x.x.x regardless if I am hard wired or wireless. Others devices on the network from PCs to macs to I phones and droids not have any problems. I tried the Mac that is having trouble on different routers at other locations and I have the same problem?
ASKER
jeffreychorba

Also, I do not have dhcp client Id configured
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Craig Beck

Like I said in my last post, see if the DHCP Client ID is configured on the MAC.

I had a school which was having issues with ~30 MACs.  The IT Admin there had set DHCP Client IDs on them and they wouldn't pull IP addresses.  We removed the ID and all was fine.
Craig Beck

Ok I didn't see your last post while I was writing mine.
Craig Beck

All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER CERTIFIED SOLUTION
strung

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
strung

Also make sure the Mac firewall is disabled.
ASKER
jeffreychorba

Did the trick. Thanks alot