My Exported Server 2008 VM gets an "IP Address Conflict" when set to original IP, works with DHCP

Using VMWare ESXi 5.0. I had to move a 2008 server vm to another hypervisor. Found that I could not use VSphere to Migrate the VM, had to use VMware Stand Alone Converter.

Original VM is shut down.
If I set the IP address of the moved VM to it's original value, I get a "IP Address Conflict" message and networking stops. If I set the IP to a different value than everything works.

I've verified that there is nothing on the network using this IP, issue is internal to this moved vm.

I know that on migrating Linux vms you need to delete /etc/udev/rules/70-persistant-net file and reboot server before static IP is recognized. Wondering if there is an equivalent file to delete in
adamant40Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
how many ethernet cards do you have in the VM?

e,.g. ifconfig at the console when VM is booted, do you have eth0 and eth1?

there is an issue with Linux, and the udev rules based on mac address, when cloning on a Hypervisor.

I would delete all the udev rules, and apply IP address.
0
arrorynCommented:
Nothing that I know of that needs to be deleted on a 2K8 machine.

Presumably you've confirmed the IP address doesn't exist by pinging it when you have the "new" machine set to a different address. Try flushing the ARP cache of your switch(es)?

Aside from that, got the following from the VMware KB:

Resolving TCP/IP stack issues on the virtual machine
To resolve TCP/IP stack issues on the virtual machine:

Remove and reinstall your virtual network adapter driver.
Verify, using the vSphere/ VI Client, that the ethernet adapter is connected and powered:

Enable and disable the NIC and ping test.
Uninstall VMware Tools and ping test.
Connect to host using the vSphere/ VI Client.
Turn off the virtual machine.
Remove the ethernet adapter.
Turn on the virtual machine. TCP/IP is not loaded.
Turn off the virtual machine again.
Add the ethernet adapter – at this point either auto assign a MAC or manually assign one.
Assign a different IP address to eliminate the possibility of duplicate IP and do a ping test.
Reinstall VMware Tools and do a ping test.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if this is Windows 2008 R2, have you removed all the Hidden Devices, and network interface.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

adamant40Author Commented:
Just one ethernet card in vm

Arroryn,
unfortuntately can't clear arp cache on switches. Have confirmed by ping and other that there is nothing using IP. Thought for sure your instructions would work, forgot about version of VMware tools. Unfortunately, no change.
0
adamant40Author Commented:
Checked and did not find any hidden devices to remove.
0
adamant40Author Commented:
I've deleted the copied vm. I've set the original to DHCP and am going to try copying it over (8 more hours) and then deleting the VMWare tools, and then setting a static IP. Gonna close this ticket until I find out if this works or not.
0
adamant40Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for adamant40's comment #a39475043
Assisted answer: 500 points for arroryn's comment #a39474885

for the following reason:

I did not get a solution, but I did get good help from arroryn. Gave me another idea to try.
0
adamant40Author Commented:
Found the 100% fix in case someone has this problem.

Locate this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Click Edit > New, and click DWORD Value.
Type ArpRetryCount.
Right-click the ArpRetryCount registry entry and click Modify.
In the Value box, type 0 and click OK.
Exit the Registry Editor.
Shut down the guest operating system and power off the virtual machine.
Change the virtual machine back to a network vSwitch with the uplink.
Power on the virtual machine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adamant40Author Commented:
JUST found that answer (after 10 hours of google searching).  It does make sense for it to be selected as answer but would still like points left as assigned.

Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.