Cisco archive command

I've got cisco archiving setup on all of our routers, as well as backup kron jobs. Info can be seen at bottom.  However, I'm noticing on my kron backups, that the full config is not being backed up!  It just stops at random spots in the config, regardless of wether it's a kron backup or an archive backup to the ftp server.   I have even tried multiple ftp servers, with the same result.  Any ideas?

Config:
archive
 log config
  notify syslog contenttype plaintext
  hidekeys
 path ftp://192.168.1.155/192.168.21.1.doc
 write-memory
 time-period 10080
-------------------------------------------------------------------
ip tcp synwait-time 10
ip ftp source-interface Vlan1
ip ftp username ********
ip ftp password ********
-------------------------------------------------------------------
kron occurrence Backup at 3:00 Mon recurring
 policy-list Backup
!
kron policy-list Backup
 cli show run | redirect ftp://192.168.1.155/192.168.21.1.doc
!
sstireAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rauenpcCommented:
Maybe instead of "cli show run" do a "cli copy run ftp://xxxxx"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sstireAuthor Commented:
Rauenpc, I gave it a try.  Still a no go.  Only partial config shows up on multiple ftp servers.  I even tried a manual ftp backup and even it's a partial config....
0
sstireAuthor Commented:
Also, I forgot to mention that this is affecting my archive jobs as well.  I did test with TFTP just a min ago and it was a complete config...  What would allow the tftp to work when the ftp will not?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

rauenpcCommented:
I have no idea why you would be getting a partial configuration. One thing you could try is embedding the username and password in the ftp url.

 ftp://username:password@192.168.1.155/192.168.21.1.doc

Also, are you able to use tftp instead, or are you required to use ftp?
0
sstireAuthor Commented:
I would love to use tftp if I could at least secure it with credentials, so ftp is our only option that I'm aware of.  One thing I've noticed, is I'm using the same ftp util on both my laptop and the server.  It's always worked great, but I want to test with a different ftp server util.  Do you have any suggestions?  I'm currently using freeftpd because it's well, FREE, and runs as a service weather I'm logged in or not.
0
rauenpcCommented:
filezilla ftp is my server of choice on my laptop.
0
naderzCommented:
Try this:

kron policy-list Backup
 cli terminal length 0
 cli show run | redirect ftp://192.168.1.155/192.168.21.1.txt
0
sstireAuthor Commented:
Naderz, great suggestion, I thought for sure you were on to something there, but it didn't help unfortunately.  This happens even when I do a manual copy run ftp as well.  Is there an ftp timeout or something on the router?  It only takes about 3 seconds for it to upload the configs....
0
naderzCommented:
Well, it was worth a try :)

If "copy run ftp" at command prompt is also having the issue, then I say there is something on the ftp server setup that needs to be reviewed; e.g. username, password, etc. I don't know of any timeouts on the router. There may be timeouts or limits on the server. I know FileZilla has bandwidth limits.

Have you tested with tftp just to prove things work? And, have you tried another ftp server? I would review the sever logs for errors and more information.
0
sstireAuthor Commented:
I tried switching to passive mode on the router, but that didn't improve anything, still only a partial config.  I don't understand why this has worked for several years and all of a sudden start this crap.  I'm reinstalling freeftpd in last ditch efforts.  I tried 4 other ftp utils which all claimed to have sftp, but in reality they were ftps.  The one that cisco recommends is Titan Enterprise for $1200.  If I can't get this to work, then I guess I'll just buy the dang thing...

http://www.webdrive.com/purchase/tnpricing.html
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.