Mail having problems with Exchange connector since upgrading to Mac OS Mountain Lion

Ever since I upgraded to Mountain Lion on my 27" iMac i've had issues getting consistent email from my Exchange server. It allows me to connect, gets existing mail and folders, but doesn't get new mail as it comes in. It wasn't a problem with the previous OS's. I'm not getting any errors, just no mail. Thanks.
LVL 1
sdedolaCTOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SeanSystem EngineerCommented:
Do you have it setup as a POP account? if you do you need to set your send/receive schedule for ever 5 min or so or make sure you have the account setup as an exchange account.
0
sdedolaCTOAuthor Commented:
When setting up new accounts in Mail there is an option to setup as Exchange. It's a type of iMap, but with some "under the covers" differences I don't completely understand. I know that any changes, deletes and responses are visible from all my different clients (Outlook on Win7, iPhone, etc.).

Hope that helps diagnose.

Thanks.
0
SeanSystem EngineerCommented:
you may need to setup your send/receive schedule if your using imap.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

sdedolaCTOAuthor Commented:
Hey thanks for the input, but I've covered the "Send/Receive" stuff. Pretty basic, right? It doesn't pickup mail even when I tell it "Go get the mail" manually. Again, no error message, just... nothing.

If you've got some other ideas, let me know.
0
SeanSystem EngineerCommented:
I would recommend trying to get the email account setup as an exchange account rather than an imap. Not sure why imap is not working but the exchange setting should do the trick.
0
sdedolaCTOAuthor Commented:
Ok, I guess I was unclear: I am using the Exchange client in Mail. That's the one that's not functioning like it used to. All the symptoms I described are when I use the Exchange client.

Hope this clarifies. Thanks.
0
Tim LapinComputer Consultant (Desktop analyst)Commented:
Hmm, sounds like Mail is using a "cached" version of the database and not updating it.

One thing to try:  Delete the account and recreate it.  
Please note that this assumes all of your mail is on the server.  Otherwise, Mail will delete the messages, as that is its habit.  Should you have any mail stored locally for that account, make sure it has been moved to a separate folder outside the account folder hierarchy.

Location issues:
Are you onsite or is this a connection from outside the organization?  You might need to invoke a VPN connection if outside.
0
sdedolaCTOAuthor Commented:
Hi Tim,

Thanks for your response. I have deleted and re-added the account several times in the past. It always works the first time it's created, bringing in the most recent email along with all the folder structure. After that, it stops picking up new email or updating the folders if email is moved or deleted from another device.

This is offsite, at my home. I've never required a VPN in the past for this to work. It has only been happening since I upgraded to the newer version of Mail.
0
Tim LapinComputer Consultant (Desktop analyst)Commented:
OK, I did some more digging and found that you are not alone with Mail issues after upgrading to Lion (10.7.x)

There seem to be 2 processes that might need to be done, one at your end and one at the server end.

Your (client) side:

1.In Finder, open your Utilities folder and double-click Keychain Access
2.Once Keychain Access loads, in the menubar, click "Keychain Access" -> "Preferences"
3.In the Preferences window, click "Certificates"
4.Change the dropdown for "Online Certificate Status Protocol (OCSP):" to "Off"
5.Change the dropdown for "Certificate Revocation List (CRL):" to "Off"
6.Close the Preferences window
7.Quit Keychain Access



Server side:

1, Open IIS Manager on yourExchange 2007/2010 Client Access Server
2, Select "Default WebSite" then "EWS"
3, Select"Authentication"
4, Right click on "BasicAuthentication"
5, Select "Enable"


Both are from the following Apple discussion:
https://discussions.apple.com/thread/3197798?start=0&tstart=0



NOTE:
Lion requires at least Exchange Service Pack 1 with update Rollup4 or later.

EDIT:  I just re-read your initial email and noticed that you wrote MOUNTAIN Lion.  My bad, as they say.  Still, I would look at the fixes I mentioned as Mountain Lion is not all that different.  It couldn't hurt, that is for sure.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sdedolaCTOAuthor Commented:
Thanks. I'll try this when I'm back from my trip in a couple weeks.

Hi tim,

Just read your edit. I can try this fix, but the problem didn't start with my upgrade to Lion, only when I moved to Mountain Lion. Would it still be worth my time?

Stephen
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.