office 2010 only shows Desktop and my documents and gives error when trying to click on desktop

Ok here is what I have:

Citrix presentation server 4.0
2008 R2 DC
windows 7 clients

I have office 2007 installed on the citrix servers and all work fine. I have to upgrade to 2010. So I uninstalled 2007 from one of the citrix servers and installed 2010 for testing.

All seem to work except, when I login as a user and try to open a file location from within any of the office applications such as word, or excel and or try to attach a file in outlook it defaults to My documents (which in our case id redirected to home folder) img1, and when you click on the drop down it shows Dekstop. When I click on desktop I get this error (2).

I researched and I know about the policy for the trusted locations which will not work in our case as we have many locations one of which the local drive on the client that the users need to be able to access.

What I am looking for is the typical behavior of when you click on the drop down it will show you all the drives including the shared drives and the local drives. Again this works just fine in 2007 and 2003.

What is the problem here? I tested with domain admin account and with a user account and they both have the same issue, so it is not a permissions issue.

While testing though I came across what seemed to be a bug, so I changed the default file location to one of the shred drives, and when I try and open a file let us say in word, it takes me directly there. But, if I click on the drop down and I want to go hight I can go to My network places and entire network and then Microsoft windows network and then our domain and the server and the share. If I click on my network places then I see Entire network and my web places (Img3) if I click on my web places it fails (Img4) as it should but then Right after that failure if I click on the drop down I finally see the user (my computer) and I can browse to it (Img 5).

PLEASE HELP!
img1.png
img2.png
img3.png
Img-4.png
img5.png
aliitsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

aliitsAuthor Commented:
Sorry I forgot, the citrix servers are 2003 SP1
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Do you have a loopback policy which hides drive letters.
0
aliitsAuthor Commented:
not sure what you mean by that? is this a user configuration or computer configuration? where would the settings be located?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

aliitsAuthor Commented:
come to think of it I do not think I have anything like that as in 2007 it does show the drive letters.
0
barrykflCommented:
Check your access right on Desktop ....try simulate it using the admin is able to aceess anywhere

I believe u have made something wrong ...on sharing session ...different account sharing the same sessions ..so inherit last account 's short cut or access right right try remove all terminal services connection and connect again.
0
aliitsAuthor Commented:
I tried that as in my comments I tried with a domain admin account and tried with a domain user account no difference.

I did delete the terminal service profile and recreated and tested no change. for both the domain admin and the user.

Plus, I have not made any changes to these existing users, all I did is upgrade from 2007 to 2010. And  remember 2007 works just fine.

And, if you read the notes you can see towards the end that if I add the share to the trusted locations and then go up the hierarchy and get to the point where it errors out when trying to get to the web shares, after that it will actually display the correct drives as expected.
0
aliitsAuthor Commented:
I added the user to the local Admin group on the client and tried that and still no solution, when I click on the desktop I still get the error mentioned in my post.
0
aliitsAuthor Commented:
I made sure the webica file on the client has the correct setting to give full access to the local client.

I confirmed this by launching the published explorer from citrix and I am able to access all the drives shared and local no problem.

Again I know it seems like a permissions issue but I checked everything and I do not see where the problem is, also why does 2007 work fine.
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Go to your Group Policy Management snap-in.  Navigate to OU where the Citrix server resides.  Take a look under Link Group Policy Objects and Group Policy Inheritance tabs and see what policies are applied.  Create a report of each policy and save it.  

You haven't provided your Citrix version.  Some versions of Citrix has policies capabilities and this might be a Citrix policy issues.  Please provide us the version of your Citrix (i.e. Presentation Server 4.5, XenApp 6.0, etc.).
0
aliitsAuthor Commented:
Citrix Presentation server 4.0
We are not using any citrix policies.
I will check the AD policies and report back, is there a specific setting I need to look for?
0
aliitsAuthor Commented:
I think this may be the problem, I did not think there is a relation since this has been happening fo ryears now and never caused an issue.

This citrix environment is inherited and from day one I noticed that whenever a new user is created and we try to setup their outlook to save the archive file in their home folder (H:\) we always get this error (Citrix Error image attached).

From what we gathered this was due to previous admin installing applications while logged in to the citrix server with his own accounta s a domain admin. And therefore all users try to locate their intial home folder at H:\Desktop that is tied to his account that they do not have access to and or does not exist anymore.

I tried to search the registry for this entry H:\Desktop and could not find that anywhere.

I really think this is the issue, not sure but it would be logical. So, how do I fix this problem with the users profiles defaulting to this x admin H:\Desktop?
0
aliitsAuthor Commented:
Again this issue with citrix not finding the H:\Desktop has been going on for a long time, the difference is with office 2003 and 2007 we would just click OK and then browse to the correct home folder. But I think office 2007 does not like that.
0
aliitsAuthor Commented:
here is the citrix error
citrix-error.png
0
aliitsAuthor Commented:
I found the entry in registry, I assume this is the problem. What does it need to be set to on citrix server?

this entry is in the Shell Folders key
registry.png
0
aliitsAuthor Commented:
Another H:\Dekstop in the user shell folders key
user-shell-folders-entry.png
0
aliitsAuthor Commented:
Another entry in Install source for H:\Desktop
Install-source-entry.png
0
aliitsAuthor Commented:
ok I am finding many places now with H:\Dekstop in install source and that would explain having this error also sometimes when trying to install software. So I am assuming I either have to delete these keys and or change them to something?
0
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Check on your machine as to what it is set to and change it to that (I think by default it is c:\documents and settings\%username%\desktop ...)
0
barrykflCommented:
Are u using roaming profile for acocunts / map terminal profile to H , or tried before or redirect foler ..etc...maybe it kept the historial setting.

Change it to default or using a new account to compare, if new account has such issue H:\

then it is starngle and u may change the deafault regsitry before.
0
aliitsAuthor Commented:
no roaming profile. We are redirecting folders (My documets, etc) the H:\ drive is the home folder for the user and is set in the user profile and remote desktop profile.

Which entry Am I supposed to change and what do I change it to? Which entry controls the default behavior for all users?
0
aliitsAuthor Commented:
I am really disappointed at the lack of response to this. I found the solution by while further troubleshooting, hope this may help someone:

As I said we have a policy redirecting user desktop to the home folder H:\Desktop. The issue here was that when the user logs in for the first time that Desktop subfolder on H:\ is not created yet.
What I did to test this is I created a new user and then I created the Folder Desktop under H:\ before the user logs in. I then logged in and launched office 2010 word and went to open a file and browsed to Desktop as before and I actually was able to get to the desktop and did not receive the error I was getting before.

Now, I have the question, why is the Desktop folder not created automatically? at what point should it be created by the policy (When the user logs in first)? Can someone help me with a script that I can use in the login script to check if the user has that folder and if not create it? even better is there a way to run this script only for new users?

Thank you
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aliitsAuthor Commented:
no one else gave a solution to this
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.