troubleshooting Question

Debugger stepping into non-user code

Avatar of ElrondCT
ElrondCTFlag for United States of America asked on
.NET ProgrammingVisual Basic.NET
3 Comments1 Solution423 ViewsLast Modified:
I had a hard disk crash a couple of weeks ago. (Yuck, but online backup really worked.) After reinstalling Visual Studio 2008, when I run an application with the debugger, going step by step (pressing F8) is causing the debugger to step into non-user code marked with <Global.System.Diagnostics.DebuggerNonUserCodeAttribute()>. I have the debugging option Enable Just My Code checked, which the documentation indicates should cause code with that attribute to be skipped.

I've tried unchecking and rechecking the Enable Just My Code box, which makes no difference. Any ideas on what may be causing this to happen? Anything other than holding down the Shift while pressing F8 to prevent the unnecessary steps?
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 3 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros