Remote printing not working as expected

Guys, I have a client with three offices. In one, the server is hosted and a number of users from each of the two other offices connect into their profile on a virtualbox Windows 7 machine within the Windows 7 'server'.

Due to suggestions made in a previous post (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_28219806.html), I thought I was successfully be able to create printer connections. They worked... at least until the PCs rebooted every night.

There are a couple of issues I need your assistance on - they're as follows:

1/ I don't seem to be able to set up one single printer that will work with all users in that same office, given I'm setting each up with a TS port appropriate to the indivualy machine and it won't work unless I set up the printer with one user and share it (but all users are in and out and not always leaving their PCs on, so this solution will require change on their part.

2/ Running into the problem above and because the clients needed all users printing ASAP, I got them going by setting up '<printer name> for <person's name>' for each user (there are only 15 users currently using the server in this way). After some attemptes, the printers I set up kept disappearing after a few minutes and a few prints. Eventually, in their place was left a single instance of the printer name (minus the 'for <person's name>' ending) with a '(redirected #)' where # was a number. Any idea what this is and how to fix it?

Looking forward to getting these guys back up and printing shortly - thanks in advance for your help.
Servant-LeggieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Servant-LeggieAuthor Commented:
On the printer redirection, the redirected printer cannot be removed (at least, I haven't found a way) and, after attempting the set a couple of the other attached printers as defaults, the redirected printer would automatically make itself default again. Something sounds a bit whacky!
0
minlauCommented:
Hi,

Verify that the IP's on the printers or the printers attached to PC Via USB are STATIC.

Once static IP's are set you will be able to install the printers on all workstation and restarting it at day or night will not change anything.
0
Servant-LeggieAuthor Commented:
minlau, the printers are statically set. They are connected to locally and never have a problem, whether PCs are turned off or not. It's only on the remote server that the issues come up.
0
Servant-LeggieAuthor Commented:
Issue resolved! Turns out that the printer appearing in the remote session listed as 'redirected' was the printer shared out on the remote computer by the local computer. While I have no idea why I wasn't able to create a remote printer that wouldn't delete overnight, as soon as I used the redirected printer to print, it worked a treat.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Servant-LeggieAuthor Commented:
I was able to isolate the problem and resolve it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.