Wireless Controller 2504 issues

Hello Cisco Pros.

Have an issue that has taken a lot of my time trying to figure out a solution.

We have a Cisco  Wireless 2504 directly connected to a 3560E on port 47 and port 47, has the following command:

interface GigabitEthernet0/47
 switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 macro description cisco-wireless
 spanning-tree bpduguard enable

We have 12 APs AIR-LAP1041N-A-K9 .

on 2nd, 3rd and 4th Floor there's a switch on each floor, same configuration.

there are 3 APs on 2nd floor, so the same for the 3rd and 4th.

Here's the configuration for ports where APs are connected to the aboved mentioned switches.

interface GigabitEthernet1/0/43
 description Cisco WAP
 switchport access vlan 10
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/44
 description Cisco WAP
 switchport access vlan 10
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/45
 description Cisco WAP
 switchport access vlan 10
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/46
 description Cisco WAP
 switchport access vlan 10
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 macro description cisco-wireless | cisco-wireless | cisco-wireless | cisco-wireless
 auto qos trust
 spanning-tree portfast
 spanning-tree bpduguard enable

Users keep losing connection, also it takes 2 hours to download 45MBs, definitely something is going on.

Do you have any suggestions?

regards and thanks in advance.
Katrach0System AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan LanhamCommented:
What are you basing your speed tests on? A local file download / upload? Or a download via your Internet gateway?
0
Katrach0System AdminAuthor Commented:
In doing computer updates and downloading files from the internet.
0
anoopkmrCommented:
kindly remove the  below configurations from AP connected ports . and try

 switchport trunk native vlan 10
 switchport mode trunk
  switchport voice vlan 100
 spanning-tree bpduguard enable

also for testing remove the below commands from all interface as well
srr-queue bandwidth share 1 30 35 5
 priority-queue out
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Katrach0System AdminAuthor Commented:
Made those changes, still the same. ( did those changes like 15 mins ago)
0
anoopkmrCommented:
What type of authentication for users ?
what is the error getting at the client
is that ap disjoining from  wlc at the time of issue
0
Katrach0System AdminAuthor Commented:
What type of authentication for users ?
Answer: WPA2

Clients don't see an error, they just lose connection.

the AP doesn't disjoin from WLC.
0
Craig BeckCommented:
When trying to address bandwidth issues, I'd look at the QoS config if it's applied to a port.

However, the config for the port where the WLC connects is a bit iffy.  Change it to this...

interface GigabitEthernet0/47
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk


Also note you shouldn't use BPDU Guard on this port.

Unless you're using FlexConnect (or H-REAP as it was formerly called), you should configure ports where APs connect as access ports not trunk ports.  They transport all traffic to the WLC via CAPWAP, then the traffic is placed on the correct VLAN at the WLC.  So, where APs connect you should just have this...

interface GigabitEthernet1/0/46
 description Cisco WAP
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree bpduguard enable
0
Katrach0System AdminAuthor Commented:
Craig,

I made the changes you said and I got this.

%Portfast has been configured on GigabitEthernet1/0/44 but will only
 have effect when the interface is in a non-trunking mode.
4ThFlr-2960S(config-if)# spanning-tree bpduguard enable
4ThFlr-2960S(config-if)#
4ThFlr-2960S(config-if)#interface GigabitEthernet1/0/45
4ThFlr-2960S(config-if)# description Cisco WAP
4ThFlr-2960S(config-if)# switchport access vlan 10
4ThFlr-2960S(config-if)# switchport mode access
4ThFlr-2960S(config-if)# spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface  when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION
0
Craig BeckCommented:
They're standard messages. Did performance improve?
0
Katrach0System AdminAuthor Commented:
Still users losing connection and when connected it takes a lot of time to open even the Google home page...
0
Craig BeckCommented:
Can you ping the WLC consistently from a wired host on the network?
0
Katrach0System AdminAuthor Commented:
Yes, no ping issues to WLC.
0
Craig BeckCommented:
Are you seeing any messages in the event log on the WLC which mention TX power?  If so can you post them?
0
Katrach0System AdminAuthor Commented:
Ended up calling Cisco and this is what they did.

Set Dynamic Channel Assignment (DCA) to automatic

Step 1 Disable the 802.11a/n or 802.11b/g/n network as follows:
a) Choose Wireless > 802.11a/n or 802.11b/g/n > Network to open the Global Parameters page.
b) Unselect the 802.11a (or 802.11b/g) Network Status check box.
c) Click Apply.
Step 2 Choose Wireless > 802.11a/n or 802.11b/g/n > RRM > DCA to open the Dynamic Channel Assignment (DCA) page.
Step 3 Choose one of the following options from the Channel Assignment Method drop-down list to specify the Cisco WLC’s DCA mode:
• Automatic—Causes the Cisco WLC to periodically evaluate and, if necessary, update the channel assignment for all joined access points. This is the default value.

Step 4 Click Apply.
Step 5 Reenable the 802.11 networks as follows:
a) Choose Wireless > 802.11a/n or 802.11b/g/n > Network to open the Global Parameters page.
b) Select the 802.11a (or 802.11b/g) Network Status check box.
c) Click Apply.
Step 6 Click Save Configuration


Set Transmit Power Control (TCP) to automatic

Step 1 Choose Wireless > 802.11a/n or 802.11b/g/n > RRM > TPC to open the 802.11a/n (or 802.11b/g/n) > RRM > Tx Power Control (TPC) page.
Step 2 Choose the Transmit Power Control version from the following options:
• Interference Optimal Mode (TPCv2)—For scenarios where voice calls are extensively used. Transmit power is dynamically adjusted with the goal of minimum interference. It is suitable for dense networks. In this mode, there could be higher roaming delays and coverage hole incidents.
We recommend that you use TCPv2 only in cases where RF issues cannot be resolved by using TCPv1. Please evaluate and test the use of TPCv2 with the assistance of Cisco Services.
Note
• Coverage Optimal Mode (TPCv1)—(Default) Offers strong signal coverage and stability. In this mode, power can be kept low to gain extra capacity and reduce interference.

Step 3 Choose one of the following options from the Power Level Assignment Method drop-down list to specify the Cisco WLC’s dynamic power assignment mode:
• Automatic—Causes the Cisco WLC to periodically evaluate and, if necessary, update the transmit power for all joined access points. This is the default value.
Step 6 Click Apply.
Step 7 Click Save Configuration.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Craig BeckCommented:
You didn't say these default options were turned off!

DCA and TPC are turned on by default and shouldn't really be turned off.
0
Katrach0System AdminAuthor Commented:
I had this issue going on and on, after these changes were made, wireless started working as it should. A wireless engineer ended up doing this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.