Avatar of seanab
seanab asked on

using xcopy to copy a file says Invalid Parameter....

Trying to run xcopy:

xcopy \\%logonserver%\netlogon\PipelineSegments.store C:\Program Files (x86)\Common Files\Microsoft Shared\VSTA\Pipeline\

fails with Invalid parameter.. I've tried it using this as well:

xcopy "\\%logonserver%\netlogon\PipelineSegments.store" \\%computername%\Program Files (x86)\Common Files\Microsoft Shared\VSTA\Pipeline\

that fails as well..

Just to make sure I wasnt going nuts I did

xcopy c:\test.txt c:\temp and that worked...

so is it something to do with UNC paths?
Microsoft DOS

Avatar of undefined
Last Comment
seanab

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Bill Prew

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
seanab

Yes I tried that as well, says "invalid drive specification"  I have confirmed I have access to the drive.  If I do not use an UNC path it works, but that does not help me as this is going on during the logon script...
ASKER
seanab

billprew, yes that was actually right.. I just couldnt run it from a command prompt.. I ran it from a *.cmd script and it worked.. also I couldnt use "\\%logonserver%\.... but "%logonserver\.."
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck