• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1537
  • Last Modified:

Cannot install Windows 7 Home Premium SP1 Windows updates. No way, no how!

I'm at the end of my rope.  I have a client with TWO PCs, one an HP laptop (620), the other a Gateway desktop.  One SP1, the other no SP.

Dealing with the HP 620, it's Windows 7 SP1. There are 72 updates waiting to be installed and every last update fails.  It goes through them all, supposedly installing one after the other, but at the end it says they failed to install.  All 72 of them.

The two error codes are: 80070308 and 9C57.  Have also seen 0643.  Have tried all fixes prescribed by Microsoft.

Here's what I have tried:

1. .net repairs of all types and descriptions. Complete remove and reinstall per Microsoft cleanup tools.
2. .net verification. All versions verify properly.
3. Various Microsoft fixit tools.
4. The Windows update troubleshooter in COntrol Panel.  Says Update was fixed, but no difference.
5. Numerous restarts.
6. Disable antivirus (eset)
7. Microsoft's online virus scanner.
8. SFC (no problems)
9. Registry permission checker/adding Administrator permissions where missing.
10. Manual updates, pick a single update, download the KB file, run it - it fails.
11. "Repair your computer" on restart.
12. New Windows user account.
13. Disabled all startup programs and unnecessary services.

It's odd that I rarely encounter this error, and yet the client has two computers with the same issue, on 2 different version of the OS (1 Sp1, the other non SP - and can't install it!)

I am absolutely out of ideas.  Anyone encountered anything like this before??
1 Solution
Try reinstalling SP1.  I had a W2K8 doing the same thing, and when I re-installed SP1 updates started rolling again.
DaveWWWAuthor Commented:
When I download Sp1 from the Microsoft Download Center it says I already have it installed.  Do I have to uninstall SP1 first?
Make sure the date and time are correct. Scan the PC for malware using malwarebytes and allow it to remove what it finds.
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

DaveWWWAuthor Commented:
Thanks Rindi. Both have been done, no malicious software found. No effect.
Download and run the system readiness tool


Reboot and then try updates...if the issue persist then try repair install of o.s

Nick RhodeIT DirectorCommented:
I have seen this issue with some lenovo systems which might be the same issue.  It was with update KB2647753.  Install that update by itself, reboot, and try again with the rest of the updates.  

If that is not the issue try installing some of the updates vs all of them and on each reboot do a few more etc..  Seems to me the system does not like a particular update and is causing it all to fail.
DaveWWWAuthor Commented:
NRhode, I have tried individual updates, but they don't install either.  I'll check to see about KB2647753.
No if SP1 won't re-install then forget that, I think my SP1 was corrupt so it allowed me to re-instal
Donald StewartNetwork AdministratorCommented:
I've had success by deselecting all the updates to install and scrolling down to bottom and selecting the last 5 updates and installing them. Then after a install/reboot the remainder install.

Did you check in Services that Windows Update service and Remote Call Procedure service are on?

Reset Windows Update




Reinstall Windows Update Agent (different links for different Win 7 systems (32bit and 64bit))



Run SFC /SCANNOW from a Command Prompt

Run a System Restore to a date before the problem started.

Run a Repair Install.  A Repair Install should not affect personal data or installed programs. but it never hurts to backup first.


Forgive me if I have duplicated others' suggestions.

"When I download Sp1 from the Microsoft Download Center it says I already have it installed.  Do I have to uninstall SP1 first? "
It is hard to understand why you have done this or which PC it refers to.
Dave, go to Control Panel > Programs and Features. In the left pane click on "Installed Updates". If SP1 is installed, select it and click "uninstall" located at the top of the window.
Reboot your pc. When Windows Update offers the SP1 update again, try to install it again.

If SP1 is installed and running on your pc, it will show up under Windows Edition in "System" when you go to control panel and click on "System".

I had the same problem and solved it by doing the above instruction.
DaveWWWAuthor Commented:
Thanks all. The answer was to uninstall SP1, then restart and re-install SP1.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now