Problems with failed WSUS Updates

Everyone,

  I have some servers that are failing to get Windows Updates installed automatically. They fail daily. However, if I run the updates manually they work. I have tried deleting the contents of the Software Distribution folder and rebooting the machine; but that did not work.

  I am getting the error WARNING: Download failed, error = 0x80244019 in the Windows Updates.log.

  Any suggestions are greatly appreicated.
afro4cbossAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DonNetwork AdministratorCommented:
Run Wsusutil reset on the WSUS server so that it redownloads any corrupt files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZabagaRCommented:
Aside from deleting the Software Distribution folder you could try these steps:

Save these 2 as batch files and run on the affected machines:

@echo off
Echo 1.    Stops the wuauserv service
Echo 2.    Deletes the AccountDomainSid registry key (if it exists)
Echo 3.    Deletes the PingID registry key (if it exists)
Echo 4.    Deletes the SusClientId registry key (if it exists)
Echo 5.    Restarts the wuauserv service
Echo 6.    Resets the Authorization Cookie
Echo 7.    More information on http://msmvps.com/Athif
Pause
@echo on
net stop wuauserv
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
net start wuauserv
wuauclt /resetauthorization /detectnow
Pause

---------------------------------
2nd batch script below re-registers .DLLs
----------------------------------

%windir%\system32\regsvr32.exe /s %windir%\system32\atl.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\jscript.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\msxml3.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\softpub.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wuapi.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wuaueng.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wuaueng1.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wucltui.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wups.dll
%windir%\system32\regsvr32.exe /s %windir%\system32\wups2.dll  
%windir%\system32\regsvr32.exe /s %windir%\system32\wuweb.dll
pause
0
DonNetwork AdministratorCommented:
@ZabagaR  



0x80244019  is not a Duplicate SID issue or files registered problem.

It's either the URL that the client is pointing to is wrong or the files are missing/corrupt on the WSUS server itself.
0
ZabagaRCommented:
Also, did you try the Microsoft Fix It Now of the affected machine(s)?

http://support.microsoft.com/mats/windows_update/
0
afro4cbossAuthor Commented:
Thanks for all the input everyone
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.