Internal Message routing to mail enabled PF

We moved our PF server to new location, prior to the move I replicated the PF to another server.  Currently we have networking issues and we are unable to connect to the original server.  Users are connecting to the server that has replicated PF.  

What is happening is this, users can access the PFs, emails from outside can reach the PFs but internal emails gets stuck in queue; exchange is trying to go to original PF server.  If I look at queue I see messages getting stuck and on the Next Hop Domain
my original server name shows up and Last error indicating 421 4.3.2 Service not available.  Which is true because the server is not accessible.

What I am looking for is somewhere in exchange or AD something is still pointing to my original PF server and I need to get rid of it and point it to the new server.

Who is Participating?
FundFireConnect With a Mentor Author Commented:
Looks like know bug, here is the fix:
SeanSystem EngineerCommented:
did you double check to make sure that the new database has the mail enabled public folders with the correct email addresses?
FundFireAuthor Commented:
I just found this on internet, I am give it a go:

<add key="SmartRoutingForPublicFoldersEnabled" value="True" />
FundFireAuthor Commented:
The issue was resolved by me.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.