Win2008 RDP server certificate issue

I'm having a strange problem on a Win2008 remote desktop server.  All we did was change the external IP address of the server, and we're now getting the following error message trying to connect from a remote location (see attachment).

When I examine the certificate from the remote client end, it's showing the wrong certificate. The one that comes up is the Exchange server certificate, not the RDP gateway server certificate.  But when I look directly on the RDP gateway server, it clearly shows the correct certificate name. I even checked the thumbprints on the two certs to make sure and they are definitely different.

Any ideas what's happening?
RDP-error.jpg
LVL 39
Hypercat (Deb)Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

becraigCommented:
This sounds like a mixup with your public IP address.

Are both your Exchange server and RDP server behind some sort of network device  ?

You might need to simply verify that the mapping is correct (i.e. the public IP/port) are pointing to your RDP server.
0
Hypercat (Deb)Author Commented:
I found the issue - it was a problem with the router configuration. I'm using a Watchguard router at this site, and I missed a tricky little configuration setting that was required for my policies for NATting to the internal servers to work properly.  Even though I had a NAT entry and policy set up for the RDP server, because of the way the policies were ordered and the config setting that I missed, it was finding the HTTPS NAT entry for the Exchange server first and using that rather than the NAT entry for the RDP server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
becraigCommented:
That is what I assumed to be wrong based on the issue you highlighted
(network device misconfiguration)


Great you got it corrected.
0
Hypercat (Deb)Author Commented:
I had already found the solution by the time I saw becraig's comment. However, his comment was on point so he/she gets them.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.