Disable restart after device driver installation

I have a computer running Win-7Embedded and there are times when we plug in an external SSD drive, Windows prompts for a 'Restart Now' or 'Restart Later' .  The issue is, this computer is not a "standard" pc (no keyboard/mouse) therefore the user cannot address the pop-up screen, but the computer is able to access the external drive to read/write, so I know that I have access to the drive and the custom software running in the background works just fine.

I am looking for a way to supress the  'Restart Now' or 'Restart Later' message?  

Any help is greatly appreciated!

Thanks,
arunykandAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arunykandAuthor Commented:
Anybody?
0
strivoliCommented:
Is this SSD drive always the same? Please post make and model of the SSD.
Is W7 Embedded fully patched?
0
Guru JiCommented:
You need to set your Windows Diagnostics Resolvers which basically show when Windows detects a hardware or software problem that requires the user to intervene. They can be suppressed by changing the Group policy as follows:

==> Start the Policy Editor by typing “Gpedit” in the start searchbar
==> Navigate to Local Computer Policy->Computer Configuration->Administrative Templates->System->Troubleshooting and Diagnostics->Diagnostics: Configure scenario execution level
==> Enable the policy, set Scenario execution level to Detection and Troubleshooting Only.

You do need a keyboard and mouse for one time. Let me know if that helps at all.

You can also Suppress Pop-up Messages caused by Windows error reporting services and it may work in conjunction with your Restart now or Restart later messages, so try below as well if above is not sufficient.

Disable Windows Error Reporting windows
==> Suppress pop-up error messages using HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\ ErrorMode=2

Disable startup error messages using
==> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\NoPopUpsOnBoot=1
==> (you have to add the value name NoPopUpsOnBoot as a dword).

Hope above will help u :)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.