iPhone 5 app will not install app

I had a problem with WAZE updating on an iPhone 5.  I power cycled the phone.  It did not help.  I was able to go to the applications list and remove the app.  Now I wanted to reinstall it.  If I look it up in the app store, it says installing.  I tap on it.  It takes me to the home screen, but there is no icon for it. If I go to app store and updates, it is not listed.  I've tried different wifi networks.  I've tried over the data connection.  I've restarted the phone between each of these attempts. I've signed out of the app store.  Rebooted and signed back in.  I've connected to a PC with iTunes.

It's just stuck.  It's like the app store thinks it's installing.  But it's not.  It's not far enough in the process to put an icon on the screens.  It's also not far enough that shows installed and available for updating.
Who is Participating?
THEiMANConnect With a Mentor Commented:
Hold the power and home button until the phone screen turns black. As soon as it turns black let go of both buttons and then hold the power button to turn on the phone. That should reset the settings to default. REMEMBER to release the power and home button as soon as the screen goes black so it doesnt go into restore mode.
abhuvanConnect With a Mentor Commented:
Try to remove using iFunbox . then re install.
Sikhumbuzo NtsadaConnect With a Mentor Senior IT TechnicianCommented:
Log out of Apple Store on your iPhone, and login with another account, restart, log back in with your original account, install the app.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.