Avatar of ABasin
ABasinFlag for United States of America asked on

promoting a 2012 sever to a dc in a 2011sbs domain

What going on is I’m trying to add my 2012 server as a domain controller to my 2011 sbs domain. I’ve added the role of active directory domain services without issue but when I go to promote it to a domain controller it fails right away here is the excerpt from the log adprep.log



Adprep was unable to complete because the call back function failed.


Error message: Unable to access the computer "xxxxxxx.bearvalley.com". The network path was not found.


[User Action]

Check the log file ADPrep.log, in the C:\Windows\debug\adprep\logs\20130910150013 directory for more information.



DSID Info:

DSID: 0x1811132a

winerror = 0x1f

NT BUILD: 9200

NT BUILD: 16384



Adprep was unable to update forest information.


Adprep requires access to existing forest-wide information from the schema master in order to complete this operation.

[User Action]

Check the log file, ADPrep.log, in the C:\Windows\debug\adprep\logs\20130910150013 directory for more information.


Adprep successfully stopped using the specified credentials for network connections.


Adprep successfully closed the network connection to the Active Directory Domain Controller xxxxxxx.bearvalley.com.


As you would notice It shows unable to access the server with the network path not found then a few line below it says successfully closing network connection to the server I’ve tried connecting to the network resource from command line and it works having access to the file and directories like ntds and sysvol for the replication I get no other error in any event log on either server so my question is what is it trying to access that it is not being allowed to? I’ve tried changing the security on the folders I know It is trying to access with no joy. Is there a problem with what I’m trying to do? Is it allowed? Is it a configuration issue of either server that can be resolved?
Microsoft Legacy OS

Avatar of undefined
Last Comment

8/22/2022 - Mon

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.